(POJ 1511)Invitation Cards 有向图来回最短路 + SPFA (复习必看题)

Invitation Cards
Time Limit: 8000MS Memory Limit: 262144K
Total Submissions: 29342 Accepted: 9808
Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.
Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output

46
210
Source

Central Europe 1998

题意:
有一个n个节点,m条边的有向图。每条边由(u,v,w)表示,问你从一号节点到达所有其他所有节点,并从其他所有节点返回1号节点的权值之和的最小值。

分析:
从一号节点到其他所有节点的最小值,我们只需要求一遍以一号节点为起点到达其他每个节点的最短路权值即可。
关于求其他节点返回一号节点的最小值,我们只需要反向建边后,任然以一号节点为起点求到达其他每个节点的最短路权值即可。
解题的思路大致如此,但是由于题目的数据较大,floyd,dijstra,bellman-ford等无法完成。所以只能用SPFA算法实现了,SPFA的时间复杂度为O(km),k一般不大于2

关于SPFA算法讲解 见另一篇博客:
http://blog.csdn.net/stillxjy/article/details/51921051

注意:
今后,自己写最短路尽量用SPFA最优算法,以免现场赛数据较大

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
typedef long long LL;
#define INF 0xFFFFFFFF
const int maxn = 1000010;


struct edge
{
    int v,w,next;
}edges[2][maxn];

int head[2][maxn];
int e0,e1,n,m;
LL ans;
bool vis[maxn];
LL d[maxn];

void addedges(int u,int v,int w)
{
    edges[0][e0].v = v;
    edges[0][e0].w = w;
    edges[0][e0].next = head[0][u];
    head[0][u] = e0++;
    edges[1][e1].v = u;
    edges[1][e1].w = w;
    edges[1][e1].next = head[1][v];
    head[1][v] = e1++;
}

void spfa(int type)
{
    queue<int> q;
    for(int i=1;i<=n;i++)
    {
        d[i] = INF;
        vis[i] = 0;
    }
    d[1] = 0;
    q.push(1);
    vis[1] = 1;

    while(!q.empty())
    {
        int u = q.front(); q.pop();
        vis[u] = 0;
        for(int i=head[type][u];i!=-1;i=edges[type][i].next)
        {
            int v = edges[type][i].v;
            if(d[v] > d[u] + edges[type][i].w)
            {
                d[v] = d[u] + edges[type][i].w;
                if(vis[v] == 0)
                {
                    q.push(v);
                    vis[v] = 1;
                }
            }
        }
    }
}

int main()
{
    int t,u,v,w;
    scanf("%d",&t);
    while(t--)
    {
        memset(head,-1,sizeof(head));
        ans = e0 = e1 = 0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addedges(u,v,w);
        }
        spfa(0);
        for(int i=1;i<=n;i++) ans += d[i];
        spfa(1);
        for(int i=1;i<=n;i++) ans += d[i];
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值