(POj 2230)Watchcow [有向欧拉图] 输出欧拉回路

Watchcow
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8436 Accepted: 3670 Special Judge
Description

Bessie’s been appointed the new watch-cow for the farm. Every night, it’s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she’s done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she’s seen everything she needs to see. But since she isn’t, she wants to make sure she walks down each trail exactly twice. It’s also important that her two trips along each trail be in opposite directions, so that she doesn’t miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input

  • Line 1: Two integers, N and M.

  • Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
    Output

  • Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
    Sample Input

4 5
1 2
1 4
2 3
2 4
3 4
Sample Output

1
2
3
4
2
1
4
3
2
4
1
Hint

OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc…
Source

USACO 2005 January Silver

题意:
一个无向图,问你如何从1号节点出发,经过每条边两次后回到1号节点,输出节点路径。并且经过每天边的两次的方向相反,保证一定存在。
话句话说就是:将无向边变成两条方向相反的有向边后,问你从1号节点出发的欧拉回路路径。

分析:
关于输出有向欧拉图的欧拉回路,由于dfs的性质,直接搜索一遍即可。
当我们递归到底层时,一定已经走过了所有的边(或者已经形成了局部欧拉回路),所以这时一定回到了起点,输出即可;再向上一层,可以把此点视为另一个欧拉回路的起点。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <map>
using namespace std;

const int maxn = 10010;
const int maxm = 50010;
struct edge
{
    int v,next;
}edges[maxm * 2];

int n,m,e;
int head[maxn];
bool vis[maxm * 2];

void addedges(int u,int v)
{
    edges[e].v = v;
    edges[e].next = head[u];
    head[u] = e++;
    edges[e].v = u;
    edges[e].next = head[v];
    head[v] = e++;
}

void dfs_euler(int u)
{
    for(int i=head[u];i!=-1;i=edges[i].next)
    {
        if(!vis[i])
        {
            vis[i] = 1;
            dfs_euler(edges[i].v);
        }
    }
    printf("%d\n",u);
}

int main()
{
    int u,v;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        e = 0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            addedges(u,v);
        }
        dfs_euler(1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值