hdu1496 Equations (hash)

Problem Description

Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0

Author

LL

Source

“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛

采用暴力hash法。将式子分为左右两部分,暴力求解左边部分的所有解。再暴力求解右边部分,加上与左边相等的部分。
由于式子中为平方。因此x1,x2,x3,x4每个均有两种解。故结果应乘以2^4

#include<iostream>
#include<string.h>
using namespace std;

int Hash[2000010];

int main(){
    int a,b,c,d;
    while(cin>>a>>b>>c>>d){
        memset(Hash,0,sizeof(Hash));
        if(a*b>0&&a*c>0&&a*d>0) {cout<<"0"<<endl;continue;}
        for(int i=1;i<=100;i++){
            for(int j=1;j<=100;j++){
                Hash[a*i*i+b*j*j+1000000]++;
            }
        }
        int ans=0;
        for(int i=1;i<=100;i++){
            for(int j=1;j<=100;j++){
                ans+=Hash[-c*i*i-d*j*j+1000000];
            }
        }
        cout<<16*ans<<endl;
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值