HDU - 1496Equations (哈希|hash)

Equations

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8641 Accepted Submission(s): 3581

Problem Description

Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0

A#uthor
LL

Source

“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛

Recommend

LL

题意:

给定一个方程的的系数,X=-100..100,求有多少个零点
直接for复杂度N^4,其实只需要哈希第4个值,枚举前3个x即可,

更优的是合并前两个,后两个,然后遍历第一个,去找第二个

复杂度O(N^2)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e6+5;
int cnt[2*maxn],a,b,c,d,ans;

int main()
{
  while(~scanf("%d%d%d%d",&a,&b,&c,&d))
  {
    if(a>0&&b>0&&c>0&&d>0)
    {
      printf("0\n");
      continue;
    }
    if(a<0&&b<0&&c<0&&d<0)
    {
      printf("0\n");
      continue;
    }
    memset(cnt,0,sizeof(cnt));
    ans=0;
    for(int i=-100;i<=100;++i)
    if(i!=0)
    {
      for(int j=-100;j<=100;++j)
      if(j!=0)cnt[a*i*i+b*j*j+maxn]++;
    }

    for(int i=-100;i<=100;++i)
    if(i!=0)
    {
      for(int j=-100;j<=100;++j)
      if(j!=0)ans+=cnt[-c*i*i-d*j*j+maxn];
    }

    printf("%d\n",ans);
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值