【HDU】 2222 Keywords Search

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 47681    Accepted Submission(s): 15186


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

题解:AC自动机入门题,注意他输入的子串可能有重复的,所以叶子节点是++而不是赋值。

好像不用释放内存就能过..时间很长。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>

using namespace std;

struct Trie
{
    Trie *ch[30],*fail;
    int val,f;
};
Trie *root;
int T,n,ans;
char s[55],s1[1000005];
queue<Trie*> q;

void buildtrie(char *s)
{
    int l=strlen(s),k;
    Trie *p=root,*q;
    for (int i=0;i<l;i++)
    {
        k=s[i]-97;
        if (p->ch[k]==NULL)
        {
            q=new Trie;
            for (int j=0;j<26;j++) q->ch[j]=NULL;
            q->val=0; q->fail=NULL; q->f=0;
            p->ch[k]=q;
            p=p->ch[k];
        }
        else p=p->ch[k];
    }
    p->val++;
}

void setfail(Trie *root)
{
    q.push(root);
    while (!q.empty())
    {
        Trie *p=q.front(); q.pop();
        for (int i=0;i<26;i++) if (p->ch[i])
        {
            Trie *tem=p->fail;
            while (tem && !tem->ch[i]) tem=tem->fail;
            p->ch[i]->fail=tem?tem->ch[i]:root;
            q.push(p->ch[i]);
        }
    }
}

void solve(char *s)
{
    int l=strlen(s),k;
    Trie *p=root;
    for (int i=0;i<l;i++)
    {
        k=s[i]-97;
        if (p==NULL) p=root;
        while (p && !p->ch[k]) p=p->fail;
        for (Trie *r=p;r && r->ch[k] ;r=r->fail)
            if (r->ch[k]->val && !r->ch[k]->f)
        {
            ans+=r->ch[k]->val;
            r->ch[k]->f=1;
        }
        if (p!=NULL) p=p->ch[k];
    }
}

int main()
{
    scanf("%d",&T);
    while (T--)
    {
        ans=0;
        scanf("%d",&n);
        root= new Trie;
        for (int i=0;i<26;i++) root->ch[i]=NULL;
        root->fail=NULL; root->val=0; root->f=0;
        for (int i=1;i<=n;i++)
        {
            scanf("%s",s);
            buildtrie(s);
        }
        setfail(root);
        scanf("%s",s1);
        solve(s1);
        printf("%d\n",ans);

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值