Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

在这里插入图片描述
Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

一道普通的深搜

遇到的问题:
输出上 每一行最后一个数字后不能有空格
每个case后要加空行
注意只能从1开始(做着做着就忘了…)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<string>
#include<string.h>
using namespace std;
typedef long long ll;

int n;
int s[21];
int a[21];

bool isprime(int b){
	for(int i=2;i<=sqrt(b);i++){
		if(b%i==0)
			return false;
	}
	return true;
}

void dfs(int cnt){
	if(n==cnt && isprime(a[cnt-1]+1)){
		for(int i=0;i<n-1;i++){
			printf("%d ",a[i]);
		}
		printf("%d",a[n-1]);
		printf("\n");
	}
	else{
		for(int i=2;i<=n;i++){
			if(s[i]==0 && isprime(i+a[cnt-1])){
				a[cnt]=i;
				s[i]=1;
				dfs(cnt+1);
				s[i]=0;
			}
		}
	}
}

int main(){
	int count=0;
	while(scanf("%d",&n)!=EOF){
		memset(s,0,sizeof(s));
		count++;
		a[0]=1;
		printf("Case %d:\n",count);
		dfs(1);
		printf("\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值