Hust oj 1754 Minimum Scalar Product(水题)

Minimum Scalar Product
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 78(40 users)Total Accepted: 41(38 users)Rating: Special Judge: No
Description

You are given two vectors v1=(x1,x2,...,xn) and v2=(y1,y2,...,yn). The scalar product of these vectors is a single number, calculated as x1y1+x2y2+...+xnyn.

Suppose you are allowed to permute the coordinates of each vector as you wish. Choose two permutations such that the scalar product of your two new vectors is the smallest possible, and output that minimum scalar product.

Input

There are multiple test cases.

For each test case, the first line contains integer number n. The next two lines contain n integers each (1<=n<=800), giving the coordinates of v1 and v2 respectively.

 Process to the end of file.

Output

For each test case, output a line X, where X is the minimum scalar product of all permutations of the two given vectors.

Sample Input
3
1 3 -5
-2 4 1
5
1 2 3 4 5
1 0 1 0 1
Sample Output
-25
6
给你俩数组,问俩数组乘积之和最小是多少
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int Maxn = 1000;
typedef long long ll;
ll a[Maxn];
ll b[Maxn];
int n;

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&b[i]);
        }

        sort(a,a+n);
        sort(b,b+n);
        ll sum = 0;
        for(int i=0;i<n;i++)
        {
            sum += a[i] * b[n-1-i];
        }
        printf("%lld\n",sum);

    }
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值