Minimum Scalar Product Kattis - minimumscalar

Minimum Scalar Product

Kattis - minimumscalar

You are given two vectors v1=(x1,x2,…,xn) and v2=(y1,y2,…,yn). The scalar product of these vectors is a single number, calculated as x1y1+x2y2+…+xnyn

.

Suppose you are allowed to permute the coordinates of each vector as you wish. Choose two permutations such that the scalar product of your two new vectors is the smallest possible, and output that minimum scalar product.

Input

The first line of the input file contains the number of testcases, T≤10

. For each test case, the first line contains integer number n. The next two lines contain n integers each, giving the coordinates of v1 and v2

respectively.

You may assume that 1≤n≤800

and −100000≤xi,yi≤100000

.

Output

For each test case, output a line

Case #X: Y

where X

is the test case number, starting from 1, and Y

is the minimum scalar product of all permutations of the two given vectors.

Sample Input 1Sample Output 1
2
3
1 3 -5
-2 4 1
5
1 2 3 4 5
1 0 1 0 1
Case #1: -25
Case #2: 6

题目大意:

有两个向量,做内积,然后你可以改变该向量的顺序,使得求出来的内积最小

思路:

非常简单,只要最大的和最小的相乘,就能达到最小,所以一个向量升序,一个向量降序就可以求得最小值

代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN =810;

typedef long long ll;
int X[MAXN];
int Y[MAXN];

bool up_cmp(const int &a, const int &b){
    return a<b;
}

bool down_cmp(const int &a, const int &b){
    return a>b;
}

int main(){


    int T;
    int n;

    scanf("%d",&T);
    for(int i=1;i<=T;i++){
        scanf("%d",&n);

        for(int j=0;j<n;j++){
            scanf("%d",&X[j]);
        }
        for(int j=0;j<n;j++){
            scanf("%d",&Y[j]);
        }

        sort(X,X+n,up_cmp);
        sort(Y,Y+n,down_cmp);

        ll ans =0;
        for(int j=0;j<n;j++){
            ans += (ll)X[j]*Y[j];
        }
        printf("Case #%d: %lld\n",i,ans);
    }

    return 0;
}

注意:

ans += (ll)X[j]*Y[j];

最终的int型要转换成longlong 型,因为32位有可能溢出

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值