离散化:区间和

题目链接:https://www.acwing.com/problem/content/804/
题意:假定有一个无限长的数轴,数轴上每个坐标上的数都是0。
现在,我们首先进行 n 次操作,每次操作将某一位置x上的数加c。
近下来,进行 m 次询问,每个询问包含两个整数l和r,你需要求出在区间[l, r]之间的所有数的和。
数据范围
−1e9≤x≤1e9,
1≤n,m≤1e5,
−1e9≤l≤r≤1e9,
−1e4≤c≤1e4
输入样例:
3 3
1 2
3 6
7 5
1 3
4 6
7 8
输出样例:
8
0
5
思路:所谓离散化就是个一 一映射的过程,例如这个题的数据范围是1e9,但是真正能用到的坐标点最多3e5(n个改变坐标,和2 * m个区间点),所以我们根本不可能开1e9的数组,就需要把这3e5个坐标离散化(另存一个数组),使得我们的操作范围变小。
代码实现:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef pair<int, int> PII;
const int INF=0x3f3f3f3f;
const int N = 3e5+5;
int n, m;
int a[N],s[N];
vector<int> alls;//存储待离散化的值
vector<PII> add, query;
//二分求出对应离散化的值
int find(int x)
{
    int l = 0, r = alls.size() - 1;
    while(l < r){
        int mid = l + r >> 1;
        if(alls[mid] >= x) r = mid;
        else l = mid + 1;
    }
    return r + 1;
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);cout.tie(0);
    cin >> n >> m;
    for(int i = 1; i <= n; i ++ ){
        int x, c;
        cin >> x >>c;
        add.push_back({x,c});
        alls.push_back(x);
    }
    for(int i = 1; i <= m; i ++ ){
        int l, r;
        cin >> l >> r;
        query.push_back({l,r});
        alls.push_back(l);
        alls.push_back(r);
    }
    //排序去重
    sort(alls.begin(),alls.end());
    alls.erase(unique(alls.begin(),alls.end()),alls.end());
    //处理插入
    for(vector<PII>::iterator it = add.begin(); it != add.end(); it ++ ){
        int x = find(it ->first);
        a[x] += it -> second;
    }
    //预处理前缀和
    for(int i = 1; i <= alls.size(); i ++ )
        s[i] = s[i - 1] + a[i];
    for(vector<PII>::iterator it = query.begin(); it != query.end(); it ++ ){
        int l = find(it -> first), r = find(it -> second);
        cout << s[r] - s[l - 1] << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值