HDU-1078___FatMouse and Cheese —— 记忆化搜索

原题地址:http://acm.hdu.edu.cn/showproblem.php?pid=1078

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12200    Accepted Submission(s): 5172

 

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

 

 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

 

Sample Input

 3 1 1 2 5 10 11 6 12 12 7 -1 -1

 

Sample Output

 37

 

题目大意:

给出示例,一个n*n的地图,每个位置放有香甜的奶酪!老鼠起始在(1,1)每次最多走k步,每次移动只能水平或垂直移动。

问老鼠最多能吃的奶酪为多少?

 

解题思路:

类似于贪心,但还是动态规划范畴,用dp数组剪枝即可

 

代码思路:

1、用dp数组存放该地址最多能吃到的奶酪,并且当其值为0时跳过

2、用另一个数组来实现每次能移动多步!

3、递归实现存放dp数组里的期望值

 

核心:

1、ans = max(ans,dfs(xx,yy)) 状态转移在这里实现不断递归,最终得到最后一个位置也是最大值的值,然后在不断返回将对应的答案记录在dp数组里;

 

2、to[4][2] = {1,0,-1,0,0,1,0,-1}   int xx = x+to[j][0]*i;  int yy = y+to[j][1]*i;   这是一种方法实现二维空间的多次扩展,即在平面内一次性走多步!!!!

 

 

代码:

#include<bits/stdc++.h>
using namespace std;
int dp[105][105], a[105][105];
int to[4][2] = {1,0,-1,0,0,1,0,-1};
int n,k;
int dfs(int x,int y) {
	int ans=0;
	if(!dp[x][y]) {
		for(int i = 1; i<=k; i++) {
			for(int j = 0; j<4; j++) {
				int xx = x+to[j][0]*i;
				int yy = y+to[j][1]*i;

				if(xx>=1&&yy>=1&&xx<=n&&yy<=n&&a[xx][yy]>a[x][y])
					ans = max(ans,dfs(xx,yy));
			}
			dp[x][y]=ans+a[x][y];
		}
	}
	return dp[x][y];
}

int main() {
	std::ios::sync_with_stdio(false);
	while(cin>>n>>k&&n>0&&k>0) {
		memset(a,0,sizeof(a));
		memset(dp,0,sizeof(dp));
		for(int i=1; i<=n; i++)
			for(int j=1; j<=n; j++)
				cin>>a[i][j];
		cout<<dfs(1,1)<<endl;
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值