2019上海网络赛(B)Light bulbs差分

There are N light bulbs indexed from 0 to N-1. Initially, all of them are off.

A FLIP operation switches the state of a contiguous subset of bulbs. FLIP(L, R)means to flip all bulbs x such that LxR*. So for example, FLIP(3, 5) means to flip bulbs 3 , 4 and 5, and FLIP(5, 5) means to flip bulb 5.

Given the value of N and a sequence of M flips, count the number of light bulbs that will be on at the end state.

InputFile

The first line of the input gives the number of test cases, T. T test cases follow. Each test case starts with a line containing two integers N and M*, the number of light bulbs and the number of operations, respectively. Then, there are M more lines, the i*-th of which contains the two integers Li and Ri, indicating that the i-th operation would like to flip all the bulbs from Li to Ri , inclusive.

1≤T≤1000

1≤N≤106

1≤M≤1000

0≤LiRiN−1

OutputFile

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is the number of light bulbs that will be on at the end state, as described above.

样例输入复制

2
10 2
2 6
4 8
6 3
1 1
2 3
3 4

样例输出复制

Case #1: 4
Case #2: 3
题意:

有n盏灯从0到n-1,现在给你m个区间(l,r),这个区间内的每个灯会发生变化,关—>开,开—>关。

问你最后有多少亮着的灯。最初灯都是关着的。

链接:

https://nanti.jisuanke.com/t/41399

思路:

差分。

我们可以利用差分来处理区间。(l)+1,(r+1)+1。

我们可以对端点进行排序,直接跑一遍2*m即可。

如果是左端点则+1,右端点-1.

区间是左闭右开只有是奇数的时候是亮的。所以R-L即可。

代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 2000+50;
pair<int ,int> p[maxn];
int main()
{
    ios::sync_with_stdio(false);
    int t, n, m, l, r;
    scanf("%d", &t);
    for(int Case = 1; Case <= t; Case++) {
        scanf("%d%d", &n, &m);
        int tot = 0;
        for(int i = 0; i < m; i++) {
            scanf("%d %d", &l, &r);
            p[tot++] = make_pair(l,1);
            p[tot++] = make_pair(r+1,-1);
        }
        sort(p, p+tot);
        int ans = 0;
        int sum = 0;
        for(int i = 0; i < tot; i++) {
            if(sum & 1) {
                ans += p[i].first - p[i-1].first;
            }
            sum += p[i].second;
        }
        printf("Case #%d: %d\n", Case, ans);
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值