杭电2795 Billboard(线段树)

10 篇文章 0 订阅
6 篇文章 0 订阅

HDU2795 http://acm.hdu.edu.cn/showproblem.php?pid=2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32859    Accepted Submission(s): 13087


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
3 5 5
2
4
3
3
3
 

Sample Output
1
2
1
3
-1
 

Author
hhanger@zju
 

Source
HDOJ 2009 Summer Exercise(5)

题目大意:

有一张长宽分别为H*W的公告牌,往上面贴单位高度(高度为1)的,宽度为W的广告。

在线查询第n个广告贴在第几行。

 

解题思路:

用线段树保存每一段的最大宽度,每次优先询问左子树,当根结点保存的数值大于需要贴入的宽度即可贴入,否则输出-1.

然后递归输出最小的一层。(要求靠左靠上)。

 

AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 200000 + 5;
const int inf = -0x3f3f3f;
int sum[maxn << 2];
int h, w, n;
void pushup(int i) {
    sum[i] = max(sum[i<<1],sum[i<<1|1]);
}
void build(int i,int l, int r) {
    if(l == r) {
        sum[i] = w;
        return;
    }
    int mid = (l + r)>>1;
    build(i<<1, l, mid);
    build(i<<1|1, mid+1, r);
    pushup(i);
}
void update(int i, int l, int r, int v) {
    if(l == r) {
        sum[i] -= v;
        printf("%d\n",l);
        return;
    }
    int mid = (l + r)>>1;
    if(v<=sum[i<<1])
        update(i<<1,l,mid,v);
    else
        update(i<<1|1,mid+1,r,v);
    pushup(i);
}
int query(int i,int l,int r,int x,int y) {
    if(x<=l&&r<=y) {
        return sum[i];
    }
    int mid = (l + r)>>1;
    int ans = 0;
    if(x<=mid)
        ans += query(i<<1,l,mid,x,y);
    if(y>mid)
        ans += query(i<<1|1,mid+1,r,x,y);

    return ans;
}
int main() {
    while(~scanf("%d%d%d",&h,&w,&n)) {
        if(h > n) h = n;
        build(1,1,h);
        for(int i = 1; i <= n; i++) {
            int len;
            scanf("%d",&len);
            if(len > sum[1]) {
                printf("-1\n");
            }else {
                update(1,1,h,len);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值