POJ 2407 Relatives

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source

Waterloo local 2002.07.01

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

欧拉函数~

Euler函数表达通式:euler(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…(1-1/pn),其中p1,p2……pn为x的所有素因数,x是不为0的整数。euler(1)=1(唯一和1互质的数就是1本身)。 
     欧拉公式的延伸:一个数的所有质因子之和是euler(n)*n/2。


这个是欧拉函数的模板~直接套公式的~

int euler(int u)
{
	int res=u,a=u;
	for(int i=2;i*i<=a;i++)
	{
		if(a%i==0) res=res/i*(i-1);
		while(a%i==0) a/=i;
	}
	if(a>1) res=res/a*(a-1);
	return res;
}


线性筛打欧拉函数表:

phi[1]=1;
for(int i=2;i<=n;i++)
{
	if(!b[i]) a[++a[0]]=i,phi[i]=i-1;
	for(int j=1;j<=a[0] && i*a[j]<=n;j++)
	{
		b[a[j]*i]=1;
		if(!(i%a[j]))
		{
			phi[a[j]*i]=phi[i]*a[j];break;
		}
		phi[a[j]*i]=phi[i]*phi[a[j]];
	}
}


这道题的代码:

#include<cstdio>

int t,n;

int euler(int u)
{
	int res=u,a=u;
	for(int i=2;i*i<=a;i++)
	{
		if(a%i==0) res=res/i*(i-1);
		while(a%i==0) a/=i;
	}
	if(a>1) res=res/a*(a-1);
	return res;
}

int main()
{
	while(scanf("%d",&n)==1 && n)
	{
		printf("%d\n",euler(n));
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值