POJ 3398 Perfect Service

105 篇文章 0 订阅

Description

A network is composed of N computers connected by N − 1 communication links such that any two computers can be communicated via a unique route. Two computers are said to be adjacent if there is a communication link between them. The neighbors of a computer is the set of computers which are adjacent to it. In order to quickly access and retrieve large amounts of information, we need to select some computers acting as servers to provide resources to their neighbors. Note that a server can serve all its neighbors. A set of servers in the network forms a perfect service if every client (non-server) is served by exactly one server. The problem is to find a minimum number of servers which forms a perfect service, and we call this number perfect service number.

We assume that N (≤ 10000) is a positive integer and these N computers are numbered from 1 to N. For example, Figure 1 illustrates a network comprised of six computers, where black nodes represent servers and white nodes represent clients. In Figure 1(a), servers 3 and 5 do not form a perfect service because client 4 is adjacent to both servers 3 and 5 and thus it is served by two servers which contradicts the assumption. Conversely, servers 3 and 4 form a perfect service as shown in Figure 1(b). This set also has the minimum cardinality. Therefore, the perfect service number of this example equals two.

Your task is to write a program to compute the perfect service number.

Input

The input consists of a number of test cases. The format of each test case is as follows: The first line contains one positive integer, N, which represents the number of computers in the network. The next N − 1 lines contain all of the communication links and one line for each link. Each line is represented by two positive integers separated by a single space. Finally, a 0 at the (N + 1)th line indicates the end of the first test case.

The next test case starts after the previous ending symbol 0. A −1 indicates the end of the whole inputs.

Output

The output contains one line for each test case. Each line contains a positive integer, which is 
the perfect service number.

Sample Input

6
1 3
2 3
3 4
4 5
4 6
0
2
1 2
-1

Sample Output

2
1

Source

Kaohsiung 2006

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

树形DP,是洛谷P2279的简化版,加了一个限制条每个空点只能与一个实点相连,但感觉也好难想啊……

据说能用最小支配集做,然而本蒟蒻连什么是最小支配集都不知道……


#include<cstdio>
#include<cstring>
#define min(u,v) u<v ? u:v

struct node{
    int to,next;
}edge[200005];

int n,head[100005],tot,x,y,f[100005][3];

void add(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}

void kkk(int u,int fa)
{
    f[u][0]=1,f[u][2]=0;
    int sum=0,inc=999999999,flag=0;
    for(int i=head[u];i;i=edge[i].next)
    {
        int v=edge[i].to;
        if(v==fa) continue;
        kkk(v,u);
        f[u][0]+=min(f[v][0],f[v][2]);
        if(f[v][0]<=f[v][1]) sum+=f[v][0],flag=1;
        else sum+=f[v][1],inc=min(inc,f[v][0]-f[v][1]);
        if(f[v][1]!=999999999 && f[u][2]!=999999999) f[u][2]+=f[v][1];
        else f[u][2]=999999999;
    }
    if(inc!=999999999 && !flag) f[u][1]=999999999;
    else
    {
        f[u][1]=sum;
        if(!flag) f[u][1]+=inc;
    }
}

int main()
{
    while(scanf("%d",&n)==1)
    {
        tot=0;
	    memset(head,-1,sizeof(head));
	    for(int i=0;i<=n*2;i++) f[i][1]=999999999;
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&x,&y);
			add(x,y);add(y,x);
        }
        kkk(1,1);
        printf("%d\n",min(f[1][0],f[1][1]));
        scanf("%d",&n);
        if(n==-1) break;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值