UVa 1151 Buy or Build

42 篇文章 0 订阅
11 篇文章 0 订阅
World Wide Networks (WWN) is a leading company that operates large telecommunication networks.
WWN would like to setup a new network in Borduria, a nice country that recently managed to get rid
of its military dictator Kurvi-Tasch and which is now seeking for investments of international companies
(for a complete description of Borduria, have a look to the following Tintin albums “King Ottokar’s
Sceptre”, “The Calculus Affair” and “Tintin and the Picaros”). You are requested to help WWN
todecide how to setup its network for a minimal total cost.
There are several local companies running small networks (called subnetworks in the following) that
partially cover the n largest cities of Borduria. WWN would like to setup a network that connects all
n cities. To achieve this, it can either build edges between cities from scratch or it can buy one or
several subnetworks from local companies. You are requested to help WWN to decide how to setup its
network for a minimal total cost.
• All n cities are located by their two-dimensional Cartesian coordinates.
• There are q existing subnetworks. If q ≥ 1 then each subnetwork c (1 ≤ c ≤ q) is defined by a set
of interconnected cities (the exact shape of a subnetwork is not relevant to our problem).
• A subnetwork c can be bought for a total cost wc and it cannot be split (i.e., the network cannot
be fractioned).
• To connect two cities that are not connected through the subnetworks bought, WWN has to build
an edge whose cost is exactly the square of the Euclidean distance between the cities.
You have to decide which existing networks you buy and which edges you setup so that the total
cost is minimal. Note that the number of existing networks is always very small (typically smaller than
8).
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
Each test case is described by one input file that contains all the relevant data. The first line
contains the number n of cities in the country (1 ≤ n ≤ 1000) followed by the number q of existing
subnetworks (0 ≤ q ≤ 8). Cities are identified by a unique integer value ranging from 1 to n. The
first line is followed by q lines (one per subnetwork), all of them following the same pattern: The first
integer is the number of cities in the subnetwork. The second integer is the the cost of the subnetwork
(not greater than 2 × 106
). The remaining integers on the line (as many as the number of cities in the
subnetwork) are the identifiers of the cities in the subnetwork. The last part of the file contains n lines
that provide the coordinates of the cities (city 1 on the first line, city 2 on the second one, etc). Each
line is made of 2 integer values (ranging from 0 to 3000) corresponding to the integer coordinates of
the city.
Output
For each test case, your program has to write the optimal total cost to interconnect all cities.
The outputs of two consecutive cases will be separated by a blank line.
A 115 Cities Instance
Consider a 115 cities instance of the problem with 4 subnetworks (the 4 first graphs in Figure 1).
As mentioned earlier the exact shape of a subnetwork is not relevant still, to keep figures easy to read,
we have assumed an arbitrary tree like structure for each subnetworks. The bottom network in Figure
1 corresponds to the solution in which the first and the third networks have been bought. Thin edges
correspond to edges build from scratch while thick edges are those from one of the initial networks.
Figure 1: A 115 Cities Instance and a Solution (Buying the First and the Third Network)
Sample Explanation:
The sample input instance is shown in Figure 2. An optimal solution is described in Figure 3 (thick
edges come from an existing network while thin edges have been setup from scratch).
Figure 2: The 7 City instance of the sample input
Figure 3
An optimal solution of the 7 City instance in which which the
first and second existing networkshave been bought while two extra
edges (1,5) and (2,4) have been setup
Sample Input
1
7 3
2 4 1 2
3 3 3 6 7
3 9 2 4 5
0 2
4 0
2 0
4 2
1 3
0 5
4 4
Sample Output

17

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

最小生成树+二进制枚举+思路~

……改了两天,最后发现是数组开小了……

对于所有购买情况,最后要添加的边都一定是什么都不购买时的最小生成树上的边,所以先kruskal一遍求出最小生成树上的边的编号,然后用二进制枚举购买哪些套餐,更新后枚举加入那些边即可构成最小生成树,更新答案即可~

(紫书上的样例描述有问题,应该是加3条边,不是2条。)


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int t,n,m,x[10001],y[10001],cnt,fa[10001],num[2000001],c[9][10001],val[9];

struct node{
	int x,y,val;
}a[2000001];

bool cmp(node u,node v)
{
	return u.val<v.val;
}

int findd(int u)
{
	return fa[u]==u ? u:fa[u]=findd(fa[u]);
}

int cal(int u)
{
	int now=0;
	for(int i=0;i<=n;i++) fa[i]=i;
	for(int i=1;i<=m;i++)
	  if(u&(1<<(i-1)))
	  {
	  	now+=val[i];
	  	for(int j=1;j<c[i][0];j++)
	  	{
	  		int k1=findd(c[i][j]),k2=findd(c[i][j+1]);
	  		if(k1!=k2) fa[k1]=k2;
	  	}
	  }
	for(int i=1;i<=num[0];i++)
	{
		int totnum=num[i];
		int k1=findd(a[totnum].x),k2=findd(a[totnum].y);
		if(k1!=k2)
		{
			fa[k1]=k2;now+=a[totnum].val;
		}
	}
	return now;
}

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		num[0]=cnt=0;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&c[i][0],&val[i]);
			for(int j=1;j<=c[i][0];j++) scanf("%d",&c[i][j]);
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);fa[i]=i;
			for(int j=1;j<i;j++)
			{
				a[++cnt].x=i;a[cnt].y=j;
				a[cnt].val=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
			}
		}
		fa[0]=0;sort(a+1,a+cnt+1,cmp);
		int ans=0;
		for(int i=1;i<=cnt;i++)
		{
			int k1=findd(a[i].x),k2=findd(a[i].y);
			if(k1!=k2)
			{
				fa[k1]=k2;num[++num[0]]=i;ans+=a[i].val;
			}
		}
		for(int i=1;i<(1<<m);i++) ans=min(ans,cal(i));
		printf("%d\n",ans);
		if(t) printf("\n");
	}
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值