HDU 1693 Eat the Trees

38 篇文章 0 订阅
Problem Description
Most of us know that in the game called DotA(Defense of the Ancient), Pudge is a strong hero in the first period of the game. When the game goes to end however, Pudge is not a strong hero any more.
So Pudge’s teammates give him a new assignment—Eat the Trees!

The trees are in a rectangle N * M cells in size and each of the cells either has exactly one tree or has nothing at all. And what Pudge needs to do is to eat all trees that are in the cells.
There are several rules Pudge must follow:
I. Pudge must eat the trees by choosing a circuit and he then will eat all trees that are in the chosen circuit.
II. The cell that does not contain a tree is unreachable, e.g. each of the cells that is through the circuit which Pudge chooses must contain a tree and when the circuit is chosen, the trees which are in the cells on the circuit will disappear.
III. Pudge may choose one or more circuits to eat the trees.

Now Pudge has a question, how many ways are there to eat the trees?
At the picture below three samples are given for N = 6 and M = 3(gray square means no trees in the cell, and the bold black line means the chosen circuit(s))


 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains the integer numbers N and M, 1<=N, M<=11. Each of the next N lines contains M numbers (either 0 or 1) separated by a space. Number 0 means a cell which has no trees and number 1 means a cell that has exactly one tree.
 

Output
For each case, you should print the desired number of ways in one line. It is guaranteed, that it does not exceed 263 – 1. Use the format in the sample.
 

Sample Input
  
  
2 6 3 1 1 1 1 0 1 1 1 1 1 1 1 1 0 1 1 1 1 2 4 1 1 1 1 1 1 1 1
 

Sample Output
  
  
Case 1: There are 3 ways to eat the trees. Case 2: There are 2 ways to eat the trees.
 

Source
 

Recommend

wangye

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

插头DP~

第一道插头DP~拜读了CDQ大神的超长论文才明白原理……其实就是思想神奇,过程和状压DP差不多的(除非写宽搜)~

推荐一个不用下载券就能下载的论文地址:http://wenku.baidu.com/view/a6dce6c76137ee06eff918d1.html

具体就是逐格搜索,主要看右插头和紧挨着的下插头,如果都有或者都没有就要与前一个格子状态相反;只有一个的话就是相反和相同的状态都有。

事实证明HDU确实是不能用%lld输出的,只能用%I64d……

(CSDN为什么又不能给自己点赞了?差评。)


#include<cstdio>
#include<cstring>

int t,n,m,a[12][12],tot,cas;
long long f[12][12][1<<12];

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);tot=(1<<(m+1))-1;
		for(int i=1;i<=n;i++)
		  for(int j=1;j<=m;j++) scanf("%d",&a[i][j]);
		memset(f,0,sizeof(f));
		f[1][0][0]=1;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
		      for(int k=0;k<=tot;k++)
		      {
		    	int b=1<<(j-1),c=1<<j;
		    	if(a[i][j])
		    	{
		    		if(((k&b) && (k&c)) || ((~k&b) && (~k&c))) f[i][j][k]=f[i][j-1][k^b^c];
		    		else f[i][j][k]=f[i][j-1][k]+f[i][j-1][k^b^c];
				}
				else if(!(k&b) && !(k&c)) f[i][j][k]=f[i][j-1][k];
			  }
			if(i<=10) for(int k=0;k<(1<<m);k++) f[i+1][0][k<<1]=f[i][m][k];
		}
		printf("Case %d: There are %I64d ways to eat the trees.\n",++cas,f[n][m][0]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值