BZOJ 3942 [Usaco2015 Feb] Censoring

6 篇文章 0 订阅

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

Please help FJ determine the final contents of S after censoring is complete

有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

 
 

Input

The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
 
 

Output

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
 
 

Sample Input

whatthemomooofun
moo

Sample Output

whatthefun

HINT

Source

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

kmp~

为什么BZOJ上USACO的题也是权限题……

正常的求法求出t字串的last[],然后用数组q[tot]模仿队列来添加字符。k为匹配到的位,那么记录一个数组f[i]来表示q数组中i这一位最多能匹配到t中的第f[i]位。每次k=f[tot],然后用kmp求出新添加一位能匹配到t中的哪一位。如果最后k==strlen(t),则这块可以去掉,tot-=m-1,否则s[i]入队,记录f[tot]=k即可~

#include<cstdio>
#include<cstring>

int n,m,last[1000001],k,tot,f[1000001];
char s[1000001],t[1000001],q[1000001];

int main()
{
	scanf("%s%s",s+1,t+1);
	n=strlen(s+1);m=strlen(t+1);
	for(int i=2;i<=m;i++)
	{
		while(k && t[k+1]!=t[i]) k=last[k];
		if(t[k+1]==t[i]) k++;last[i]=k;
	}
	for(int i=1;i<=n;i++)
	{
		k=f[tot];
		while(k && t[k+1]!=s[i]) k=last[k];
		if(t[k+1]==s[i]) k++;
		if(k==m) tot-=m-1;
		else q[++tot]=s[i],f[tot]=k;
	}
	for(int i=1;i<=tot;i++) printf("%c",q[i]);
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值