NYOJ - Same binary weight

Same binary weight

时间限制: 300 ms  |  内存限制: 65535 KB
难度: 3
描述

The binary weight of a positive  integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.

输入
The input has multicases and each case contains a integer N.
输出
For each case,output the smallest integer greater than N that has the same binary weight as N.
样例输入
1717
4
7
12
555555
样例输出
1718
8
11
17
555557

#include <iostream>
#include <string>
#include <bitset>

using namespace std;

int main(void)
{
    unsigned int n;
    while(cin >> n)
    {
        bitset <32> bs;   // 使用STL bitset来存储操作数的bit位
        int m = 0;
        while(n)
        {
            if(n&1)
                bs.set(m);
            m++;
            n >>= 1;
        }
        int count = 0;
        for(int i = 0; i < m; i++)   // 寻找到第一个01,将01转换为10。
        {
            if(bs.test(i))
            {
                count++;
                bs.reset(i);
                if(!bs.test(i+1))
                {
                    bs.set(i+1);
                    break;
                }
            }
        }
        for(int i = 0; i < count - 1; i++)  // 保持1的数量不变,将其低位全部置为1.
        {
            bs.set(i);
        }
        cout << bs.to_ulong() << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值