HDU - Palindrome(dp)

Palindrome


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 
  这题其实LCS问题,将第一个序列反转,得到一个逆序列,然后,将这个问题转化为LCS问题,那么,可以使用dp来解决,但是,这个过程中,有一个细节要注意,由于题目的     内存限制,没有优化的处理,将会出现MLE哦!这个时候可以使用滚动数组处理超内存的问题,那么,这个问题,主要的用到就是LCS + 滚动数组。下面是具体的AC代码:
  
#include <stdio.h>
#include <string.h>

#define MAX(x,y) ((x) > (y) ? (x) : (y))

int dp[2][5001];

int main(int argc , const char *argv)
{
    int n;
    char s1[5001],s2[5001];
    while(~scanf("%d",&n))
    {
    	scanf("%s",s1);
    	for(int i = 0; i < n; i++)
    	{
    		s2[n-i-1] = s1[i];
	    }
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(s1[i-1] == s2[j-1])
                {
                    dp[i%2][j] = dp[(i-1)%2][j-1] + 1;
                }
                else
                {
                    dp[i%2][j] = MAX(dp[(i-1)%2][j],dp[i%2][j-1]);
                }
            }
        }
        printf("%d\n",n - dp[n%2][n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值