8.11 G - Theme Section

                                    G - Theme Section

It's time for music! A lot of popular musicians areinvited to join us in the music festival. Each of them will play one of theirrepresentative songs. To make the programs more interesting and challenging,the hosts are going to add some constraints to the rhythm of the songs, i.e.,each song is required to have a 'theme section'. The theme section shall beplayed at the beginning, the middle, and the end of each song. Morespecifically, given a theme section E, the song will be in the format of'EAEBE', where section A and section B could have arbitrary number of notes.Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'. 

To get well prepared for the festival, the hosts want to know the maximumpossible length of the theme section of each song. Can you help us? 


Input

The integer N in the first line denotes the total numberof songs in the festival. Each of the following N lines consists of one string,indicating the notes of the i-th (1 <= i <= N) song. The length of thestring will not exceed 10^6.


Output

There will be N lines in the output, where the i-th linedenotes the maximum possible length of the theme section of the i-th song. 


Sample Input

5

xy

abc

aaa

aaaaba

aaxoaaaaa


Sample Output

0

0

1

1

2

 

题意:判断输入字符串的前后缀相等时的长度,然后判断去掉前后缀剩余字符中是否还含有与前后缀相等的字符串。

如果有,输出长度。



题目数据太水,稍微卡一下判断条件就能过.....我感觉我是水过得..

#include<stdio.h>
#include<string.h>
int next[1100000];
char s[1100000];
int main()
{
	int i,j,k,m,n,t,a,f;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%s",s);
			n=strlen(s);
			i=0;j=-1;next[0]=-1;
			f=0;
			while(i<n)
			{
				if(j==-1||s[i]==s[j])
				{
					i++;
					j++;
					next[i]=j;
				}
				else
					j=next[j];
			}
			
			
/*			for(i=0;i<=n;i++)
			{
				printf("%d ",next[i]);
			}
			printf("\n");
			
*/			
			m=next[n];
			a=0;
			for(i=next[n];i;i=next[i])
			{
				for(j=i*2;j<n-i;j++)
				{
					if(next[j]==i)
					{
						a=i;
						f=1;
						break;
					}
				}
				if(f==1)
					break;
			}
	                 printf("%d\n",a);
		}
	}
	return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值