8.15 F - COURSES

F - COURSES


 Consider a group of N students and Pcourses. Each student visits zero, one or more than one courses. Your task isto determine whether it is possible to form a committee of exactly P studentsthat satisfies simultaneously the conditions: 

 

·        every student in the committee represents a differentcourse (a student can represent a course if he/she visits that course) 

·        each course has a representative in the committee 

Input

Your program should read sets of data from the std input.The first line of the input contains the number of the data sets. Each data setis presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ...Student 1 Count1 
Count2 Student 2 1 Student 2 2 ...Student 2 Count2 
... 
CountP Student P 1 Student P 2 ...Student P CountP 

The first line in each data set contains two positive integers separated by oneblank: P (1 <= P <= 100) - the number of courses and N (1 <= N <=300) - the number of students. The next P lines describe in sequence of thecourses �from course 1 tocourse P, each line describing a course. The description of course i is a linethat starts with an integer Count i (0 <= Count i <= N) representing thenumber of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting thecourse, each two consecutive separated by one blank. Students are numbered withthe positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data arecorrect. 

Output

The result of the program is on the standard output. Foreach input data set the program prints on a single line "YES" if itis possible to form a committee and "NO" otherwise. There should notbe any leading blanks at the start of the line.

Sample Input

2

3 3

3 1 2 3

2 1 2

1 1

3 3

2 1 3

2 1 3

1 1

Sample Output

YES

NO

 题意:有p门课程,n个学生,每个学生在一个committee代表一门课程,求学生和课程的最大匹配,若最大匹配等于p,输出YES,否则输出NO。

思路:先将数据读成一张图,用匈牙利算法计算计算连通情况,最后判断所有的点是否连通,是的话输出YES,否则输出NO。

#include<stdio.h>
#include<string.h>
int a[600][600],macth[600],book[600];
int m,n;
int dfs(int x)//匈牙利算法
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(book[i]==0&&a[x][i]==1)
		{
			book[i]=1;
			if(macth[i]==-1||dfs(macth[i]))
			{
				macth[i]=x;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int i,j,k,t1,t2,sum,t,s,s1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(a,0,sizeof(a));
		memset(macth,-1,sizeof(macth));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&s);
			for(j=0;j<s;j++)
			{
				scanf("%d",&s1);
				a[i][s1]=1;
			}
		}
		
/*		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				printf("%d ",a[i][j]);
			}
			printf("\n");
		}
*/		
		sum=0;
		for(i=1;i<=n;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;//记录有多少点连通
		}
		
		if(sum==n)//判断是否所有的科目都有课代表
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值