C - Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2

题目题意:一块矩形区域存在许多油田,相邻的油田可以合并为一块,找出该矩形区域有多少块油田。

思路:由题可知,相邻包含上下左右,和左上,左下,右上,右下一共八个方向,所以用深搜从一个点出发,把能联通的所有点都进行染色,如果这个点搜索完,然后继续找一个新的点继续,记录搜索的点有几个即可。


#include<stdio.h>
#include<string.h>
int m,n;
char s[120][120];
void dfs(int x,int y)
{
	int next[10][4]={{-1,0},{1,0},{0,1},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};//方向
	int i,j,k,m,n,tx,ty;
	
	if(x<0||y<0)//越界判断
		return ;
		
	if(s[x][y]=='@')
	{
		s[x][y]='*';//将能搜索到的点进行清除
		for(i=0;i<=7;i++)
		{
			tx=x+next[i][0];
			ty=y+next[i][1];
			dfs(tx,ty);
		} 
	}
}
int main()
{
	int i,j,k;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		if(m==0&&n==0)
			break;
			
		memset(s,0,sizeof(s));

		for(i=0;i<m;i++)
			scanf("%s",s[i]);	

		int sum=0;
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(s[i][j]=='@')
				{
					sum++;//记录搜索次数
					dfs(i,j);
				}
			}
		}
		printf("%d\n",sum);	
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值