POJ2676 Sudoku

16 篇文章 0 订阅

原题链接:http://poj.org/problem?id=2676

Sudoku

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

题解

我们开三个数组,记录在所有行,所有列,所有 3×3 3 × 3 矩阵里数字 19 1 → 9 是否出现过,这样,我们就可以很方便的爆搜了。

记录行和列很好做,但是 3×3 3 × 3 的矩阵不是很好做,我们可以科学计算,当然还可以打表。。。

赠送表一个:

int pos[10][10]={0,0,0,0,0,0,0,0,0,0,
         0,1,1,1,2,2,2,3,3,3,
         0,1,1,1,2,2,2,3,3,3,
         0,1,1,1,2,2,2,3,3,3,
         0,4,4,4,5,5,5,6,6,6,
         0,4,4,4,5,5,5,6,6,6,
         0,4,4,4,5,5,5,6,6,6,
         0,7,7,7,8,8,8,9,9,9,
         0,7,7,7,8,8,8,9,9,9,
         0,7,7,7,8,8,8,9,9,9,};
代码
#include<cstdio>
#include<cstring>
using namespace std;
bool heng[10][10],zong[10][10],squa[10][10];
int pos[10][10]={0,0,0,0,0,0,0,0,0,0,0,1,1,1,2,2,2,3,3,3,0,1,1,1,2,2,2,3,3,3,0,1,1,1,2,2,2,3,3,3,0,4,4,4,5,5,5,6,6,6,0,4,4,4,5,5,5,6,6,6,0,4,4,4,5,5,5,6,6,6,0,7,7,7,8,8,8,9,9,9,0,7,7,7,8,8,8,9,9,9,0,7,7,7,8,8,8,9,9,9,};
int sq[10][10];
void in()
{
    memset(heng,0,sizeof(heng));
    memset(zong,0,sizeof(zong));
    memset(squa,0,sizeof(squa));
    char ch[10];int x;
    for(int i=1;i<=9;++i)
    {
        scanf("%s",ch);
        for(int j=0;j<9;++j)
        {
            x=ch[j]-'0';
            sq[i][j+1]=x;
            heng[i][x]=1;
            zong[j+1][x]=1;
            squa[pos[i][j+1]][x]=1;
        }
    }
}
bool dfs(int x,int y)
{
    if(x==10)return 1;
    bool flag;
    if(sq[x][y])
    {
        if(y==9)flag=dfs(x+1,1);
        else flag=dfs(x,y+1);
        if(flag)return 1;
        else return 0;
    }
    else
    {
        for(int i=1;i<=9;++i)
        {
            if(!heng[x][i]&&!zong[y][i]&&!squa[pos[x][y]][i])
            {
                sq[x][y]=i;
                heng[x][i]=1;
                zong[y][i]=1;
                squa[pos[x][y]][i]=1;
                if(y==9)flag=dfs(x+1,1);
                else flag=dfs(x,y+1);
                if(!flag)
                {
                    sq[x][y]=0;
                    heng[x][i]=0;
                    zong[y][i]=0;
                    squa[pos[x][y]][i]=0;
                }
                else return 1;
            }
        }
    }
    return 0;
}
void ac()
{
    dfs(1,1);
    for(int i=1;i<=9;++i)
    {
        for(int j=1;j<=9;++j)
        printf("%d",sq[i][j]);
        putchar(10);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int i=1;i<=T;++i)
    in(),ac();
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ShadyPi

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值