原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2147
kiki’s game
Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n* m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can’t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
Input
Input contains multiple test cases. Each line contains two integer n, m (0
Output
If kiki wins the game printf “Wonderful!”, else “What a pity!”.
Sample Input
5 3
5 4
6 6
0 0
Sample Output
What a pity!
Wonderful!
Wonderful!
题解
依然是手推PN图系列:
可以看出,只要
n,m
n
,
m
中有一个偶数就是先手必胜。
代码
#include<bits/stdc++.h>
using namespace std;
int n,m;
void ac()
{
if(n%2&&m%2)
printf("What a pity!\n");
else printf("Wonderful!\n");
}
int main()
{
while(scanf("%d%d",&n,&m)&&n&&m)ac();
return 0;
}