Cup(HDU2289) 二分法

Problem Description

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

The radius of the cup’s top and bottom circle is known, the cup’s height is also known.

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

  1. T ≤ 20.
  2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
  3. r ≤ R.
  4. r, R, H, V are separated by ONE whitespace.
  5. There is NO empty line between two neighboring cases.

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

Sample Input

1
100 100 100 3141562

Sample Output

99.999024

题目大意:

给出一个圆台的下表面半径、上表面半径、圆台的高、圆台中水的体积,求出水的高度,结果保留六位小数。

思路:

可以直接用方程来解,也可以用二分法去尝试答案,直到精度符合题目要求
由于解方程的方法比较难算,这里用的是二分法。
还有要注意的是圆台体积的计算公式,一开始由于我搞错了公式导致一直过不了。
在这里插入图片描述

AC代码:

#include <bits/stdc++.h>
using namespace std;

int main()
{
    int T;
    double r,R,H,V,h,left,right;
    double pi=3.14159265359,e=0.00000001;
    cin>>T;
    while(T--)
    {
        cin>>r>>R>>H>>V;
        left=0;right=H;
        double rr,vv;
        while(right-left>e)
        {
            h=(left+right)/2;
            rr=h/H*(R-r)+r;
            vv=pi*h*(rr*rr+r*r+rr*r)/3;
            if(vv>V) right=h;
            else left=h;
        }
        printf("%.6lf\n",h);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值