HDU 2289 Cup

C - Cup
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input

     
     
1 100 100 100 3141562
 

Sample Output

     
     
99.999024
 
二分猜数字类型的题
这类题到现在做的也不少了
基本方法就是,给定区间最大最小值,在这个区间中二分出来一个mid值,然后判断这个mid值与最优解的大小关系,从而调整区间范围。直至找到满足要求的最终解。
刘汝佳在小白书中把判断mid的过程称为构造谓词P(x)函数。做的越多也就理解的越深刻。

#include <stdio.h>
#define EPS 1e-8
#define PI 3.141592653
double r, R, H, V;
double cal(double r,double R,double h,double H)
{
    double u = h/H*(R-r) + r;
    return PI/3*(r*r+r*u+u*u)*h;
}
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
                double minn=0,maxn=100,mid;
                while(maxn-minn>EPS)
                {
                        mid=(maxn+minn)/2;
                        double cmid=cal(r,R,mid,H);
                        if(cmid<V)
                                minn=mid;
                        else
                                maxn=mid;
                }
                printf("%.6lf\n",mid);
        }
        return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值