算法竞赛入门经典(第2版) Digit Counting UVa 1225

Digit Counting UVa 1225

题目:Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence
of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of
times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:
12345678910111213
In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each
digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to
write a program to do this for him. Your task is to help him with writing this program.

题意:输入一个正整数N,不间断地列出从一到N的所有正整数,统计列举结果中数字0~9分别出现的次数。

思路:逆序循环,将每位数字对10求余放入数组的对应位置。

Sample Input
2
3
13

Sample Output
0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1
#include <bits/stdc++.h>

using namespace std;
int main(){
	int n, num;
	scanf("%d", &n);
	while(n--) {
		scanf("%d", &num);
		int a[10];
		memset(a, 0, sizeof(a));
		for(int i = num; i > 0; i--) {
			int tmp = i;
			while(tmp) {
				switch(tmp % 10) {
					case 0: a[0]++; break;
					case 1: a[1]++; break;
					case 2: a[2]++; break;
					case 3: a[3]++; break;
					case 4: a[4]++; break;
					case 5: a[5]++; break;
					case 6: a[6]++; break;
					case 7: a[7]++; break;
					case 8: a[8]++; break;
					case 9: a[9]++; break;
				}
				tmp /= 10;
			}
		}
		for(int i = 0; i < 9; i++) {
			printf("%d ", a[i]);
		}
		printf("%d\n", a[9]); 
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值