POJ 3020 Antenna Placement(二分图最小路径覆盖)

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5



题目大意:

        给定一个图,要求用最少的1*2的天线覆盖所有的‘*’区域

解题思路:

        可以转化成二分图来考虑,所有的星号都分成了“两份”,构成了二分图的AB集,相邻的星号(不包括自身与自身)在二分图AB集中存在关系,建立边(其实是拆点法构建二分图),则问题转化成了求二分图最小路径覆盖问题,因为最小路径覆盖=顶点数-最大匹配数,因为是无向图,所以最大匹配数还要再除2,这样问题就变成了求二分图最大匹配了,直接匈牙利算法


#include <iostream>
#include <fstream>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <bitset>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <list>

#define STD_REOPEN() freopen("../in.in","r",stdin)
#define STREAM_REOPEN fstream cin("../in.in")
#define INF 0x3f3f3f3f
#define _INF 63
#define eps 1e-8
#define MAX_V 100010
#define MAX_P 510
#define MAX_E 10010
#define MAX 32000
#define MOD_P 3221225473
#define MOD 9901

using namespace std;

int dx[]={0,1,0,-1};
int dy[]={1,0,-1,0};
bool s[MAX_P][MAX_P];
char mp[MAX_P][MAX_P];
int idx[MAX_P][MAX_P];
bool vis[MAX_P];
int link[MAX_P];
int n,h,w;

bool dfs(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(s[x][i]&&!vis[i])
		{
			vis[i]=true;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	//STD_REOPEN();
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&h,&w);
		memset(idx,0,sizeof(idx));
		memset(link,-1,sizeof(link));
		memset(s,0,sizeof(s));
		for(int i=1;i<=h;i++)
			scanf("%s",mp[i]+1);
		n=0;
		for(int i=1;i<=h;i++)
			for(int j=1;j<=w;j++)
				if(mp[i][j]=='*')
					idx[i][j]=++n;
		for(int i=1;i<=h;i++)
			for(int j=1;j<=w;j++)
				if(mp[i][j]=='*')
					for(int k=0;k<4;k++)	//拆点构图
					{
						int px=i+dx[k];
						int py=j+dy[k];
						s[idx[i][j]][idx[px][py]]=true;
					}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			memset(vis,0,sizeof(vis));
			if(dfs(i))
				ans++;
		}
		//cout<<n<<" "<<ans<<endl;
		printf("%d\n",n-ans/2);
	}

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值