奶牛的午餐

 
时限:1000ms 内存限制:10000K  总时限:3000ms

描述:

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

输入:

Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

输出:

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

输入样例:

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

输出样例:

3

提示:

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

#include <iostream>
#include <string>
#include <queue>
#define INF 1<<16
#define MAX_NUM 405
using namespace std;

int cow, food, drink, total;
int pre_point[MAX_NUM], flow[MAX_NUM][MAX_NUM], capacity[MAX_NUM][MAX_NUM], flow_add[MAX_NUM];

int GetSmaller(int &a, int &b)
{
	return (a < b)? a : b;
}

void BFS(void)
{
	queue<int> points;
	memset(flow_add, 0x00, sizeof(flow_add));
	flow_add[0] = INF;
	points.push(0);
	while (!points.empty())
	{
		int start = points.front();
		points.pop();
		for (int end = 1; end < total; ++end)
		{
			int differ = capacity[start][end] - flow[start][end];
			if (!flow_add[end] && differ > 0)
			{
				points.push(end);
				pre_point[end] = start;
				flow_add[end] = GetSmaller(flow_add[start], differ);
			}
		}
	}
}

int MaxFlow(int start, int end)
{
	int max = 0;
	memset(flow, 0x00, sizeof(flow));//Initialize zero_flow
	while (true)
	{
		BFS();//one time flow_add operation
		if (!flow_add[total - 1])
			break;
		else
		{
			for (int end = total - 1; end != start; end = pre_point[end])
			{//renew the flow condition
				flow[pre_point[end]][end] += flow_add[total - 1];
				flow[end][pre_point[end]] -= flow_add[total - 1];
			}
		}
		max += flow_add[total - 1];
	}
	return max;
}

int main(void)
{
	int i, j, food_like, drink_like, like;
	memset(capacity, 0x00, sizeof(capacity));
	cin >> cow >> food >> drink;
	total = food + drink + cow * 2 + 2;
	for (i = 1; i <= food; ++i)
		capacity[0][i] = 1;
	for (i = 1; i <= drink; ++i)
		capacity[food + cow * 2 + i][total - 1] = 1;
	for (i = 1; i <= cow; ++i)
	{
		cin >> food_like >> drink_like;
		for (j = 1; j <= food_like; ++j)
		{
			cin >> like;
			capacity[like][i + food] = 1;
		}
		for (j = 1; j <= drink_like; ++j)
		{
			cin >> like;
			capacity[food + cow + i][food + cow * 2 + like] = 1;
		}
		capacity[food + i][food + cow + i] = 1;
	}
	cout << MaxFlow(0, total) << endl;
	return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值