POJ 2262 Goldbach's Conjecture

题目链接:http://poj.org/problem?id=2262


Goldbach's Conjecture

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 43115
Accepted: 16490

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source


思路:水题,数据不大,暴力枚举一下就好了。详见代码。


附上AC代码:

#include <cstdio>
#include <cmath>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
int n;

bool is_prime(int x){
	if (x==0 || x==1)
		return false;
	int t = (int)sqrt(x+0.5);
	for (int i=2; i<=t; ++i)
		if (x%i == 0)
			return false;
	return true;
}

int main(){
	#ifdef LOCAL
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w", stdout);
	#endif
	while (~scanf("%d", &n) && n){
		int t = n>>1;
		bool ok = true;
		for (int i=3; i<=t; i+=2)
			if (is_prime(i) && is_prime(n-i)){
				printf("%d = %d + %d\n", n, i, n-i);
				ok = false;
				break;
			}
		if (ok)
			printf("Goldbach's conjecture is wrong.\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值