HDU 1896 Stones

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1896


Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1961    Accepted Submission(s): 1273


Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output

Just output one line for one test case, as described in the Description.
 

Sample Input

  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output

  
  
11 12
 

Author

Sempr|CrazyBird|hust07p43
 

Source

 

Recommend

lcy

思路:优先队列的应用。用优先队列来维护石头的位置和扔多远的距离,当位置一样时,距离小的优先,否则位置小的优先。因为第偶数个石头不扔,所以队列最后一定会为空。详见代码。


附上AC代码:

#include <bits/stdc++.h>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
struct pii{
	int a, b;
	bool operator < (const pii & p) const {
		if (a == p.a)
			return b > p.b;
		return a > p.a;
	}
};
priority_queue<pii> q;
int n;

int main(){
	#ifdef LOCAL
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w", stdout);
	#endif
	int T;
	scanf("%d", &T);
	while (T--){
		scanf("%d", &n);
		pii t;
		while (n--){
			scanf("%d%d", &t.a, &t.b);
			q.push(t);
		}
		int ok = 1;
		while (!q.empty()){
			t = q.top();
			q.pop();
			if (ok){
				t.a += t.b;
				q.push(t);
			}
			ok ^= 1;
		}
		printf("%d\n", t.a);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值