POJ 1962 Corporative Network

题目链接:http://poj.org/problem?id=1962


Corporative Network

Time Limit: 3000MS
Memory Limit: 30000K
Total Submissions: 3725
Accepted: 1347

Description

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input will contains only the number T of the test cases. Each test will start with the number N of enterprises (5<=N<=20000). Then some number of lines (no more than 200000) will follow with one of the commands:
E I – asking the length of the path from the enterprise I to its serving center in the moment;
I I J – informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

Source


思路:并查集的应用。与一般的并查集不太一样,它的每条边都有一个权值,而且某个节点的父节点是指定的,当然并不是一成不变的,在路径压缩时,可以改变,但必须更改该边的权值。我们存的权值是某个节点与它的父节点的距离,所以更改某个节点的父节点时,就更改其到父节点的距离,比如a的父节点是b,b的父节点是c,那么c就是根节点,在路径压缩中,要将a到c的权值更改为a到b和b到c的权值之和。详见代码。


附上AC代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 20005;
const int mod = 1000;
int p[maxn], d[maxn];
int n;
char op[5];

int _find(int x){
	if (p[x] == x)
		return x;
	int root = _find(p[x]);
	d[x] += d[p[x]];
	return p[x]=root;
}

int main(){
	int T;
	scanf("%d", &T);
	while (T--){
		scanf("%d", &n);
		for (int i=1; i<=n; ++i)
			p[i]=i, d[i]=0;
		int u, v;
		while (~scanf("%s", op) && op[0]!='O'){
			scanf("%d", &u);
			if (op[0] == 'E'){
				_find(u);
				printf("%d\n", d[u]);
			}
			else{
				scanf("%d", &v);
				p[u] = v;
				d[u] = abs(u-v)%mod;
			}
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值