HDU 1050 Moving Tables

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050


Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 30255    Accepted Submission(s): 9925



Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output

The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input

  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output

  
  
10 20 30
 

Source

 

Recommend


思路:将区间按起始位置从小到大排序,起始位置相同,按结束位置从小到大排序。因为可能起始位置比结束位置大,而一个房间只能活动一张桌子,所以不管进出如何,答案只与区间相关,因此可以将起始位置永远设置为小的那个。最后,对于一个没有被访问过的区间,计数加一,然后可以向后找出俩俩互不相交的所有区间,并标记。最终答案即为计数乘以10。注意:房间是分布在两边的,因此,当终止位置的房间号是奇数时,要将它对面的偶数房间号也置为不可访问。详见代码。


附上AC代码:

#include <bits/stdc++.h>
#define pii pair<int, int>
#define f first
#define s second
using namespace std;
const int maxn = 205;
pii num[maxn];
bool vis[maxn];
int n;

int main(){
	int T;
	scanf("%d", &T);
	while (T--){
		scanf("%d", &n);
		for (int i=0; i<n; ++i){
			scanf("%d%d", &num[i].f, &num[i].s);
			if (num[i].f > num[i].s)
				swap(num[i].f, num[i].s);
		}
		sort(num, num+n);
		memset(vis, false, sizeof(bool)*n);
		int ans = 0;
		for (int i=0; i<n; ++i)
			if (!vis[i]){
				++ans;
				vis[i] = true;
				int t = num[i].s;
				for (int j=i+1; j<n; ++j)
					if (!vis[j] && num[j].f>t){
						vis[j] = true;
						t = num[j].s;
						if (t & 1)
							++t;
					}
			}
		printf("%d\n", ans*10);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值