POJ 1840 Eqs

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15010 Accepted: 7366

Description

Consider equations having the following form: 
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source



按要求模拟即可

hash是个神奇的东西

下方代码注释部分是先三层循环后二层,正文部分是先二层循环后三层。两者都是正解,但是由于list插入比读取慢,先二层更快


/*
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<list>
using namespace std;
const int mxn=14997;
list<int>ha[mxn*2];
list<int>::iterator it;
int x,x1,x2,x3,x4,x5;
int ans=0;
int main(){
	scanf("%d%d%d%d%d",&x1,&x2,&x3,&x4,&x5);
	int i,j,k;
	for(i=-50;i<=50;i++)
	  for(j=-50;j<=50;j++)
	  	for(k=-50;k<=50;k++){
	  		if(i==0||j==0||k==0)continue;
	  		x=i*i*i*x1+j*j*j*x2+k*k*k*x3;
	  		ha[x%mxn+mxn].push_back(x);//hash //x%mxn+mxn保证hash完以后是正数 
	  	}
	for(i=-50;i<=50;i++)
	  for(j=-50;j<=50;j++){
	  	if(i==0|j==0)continue;
	  	x=-(i*i*i*x4+j*j*j*x5);
	  	//检查hash
		for(it=ha[x%mxn+mxn].begin();it!=ha[x%mxn+mxn].end();it++ ){
			if(*it==x)ans++;
		} 
	  }
	printf("%d",ans);
	return 0;
	
}
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<list>
using namespace std;
const int mxn=14997;
list<int>ha[mxn*2];
list<int>::iterator it;
int x,x1,x2,x3,x4,x5;
int ans=0;
int main(){
	scanf("%d%d%d%d%d",&x1,&x2,&x3,&x4,&x5);
	int i,j,k;
	for(i=-50;i<=50;i++)
	  for(j=-50;j<=50;j++)
	  	{
	  		if(i==0||j==0)continue;
	  		x=i*i*i*x1+j*j*j*x2;
	  		ha[x%mxn+mxn].push_back(x);//hash //x%mxn+mxn保证hash完以后是正数 
	  	}
	for(i=-50;i<=50;i++)
	  for(j=-50;j<=50;j++)
	  	for(k=-50;k<=50;k++){
	  		if(i==0|j==0||k==0)continue;
	  		x=-(i*i*i*x3+j*j*j*x4+k*k*k*x5);
	  		//检查hash
			for(it=ha[x%mxn+mxn].begin();it!=ha[x%mxn+mxn].end();it++ ){
				if(*it==x)ans++;
			} 
	  	}
	printf("%d",ans);
	return 0;
	
}



niconiconi



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值