HDOJ 1250 Hat's Fibonacci



http://acm.hdu.edu.cn/showproblem.php?pid=1250

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7490    Accepted Submission(s): 2427


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 


Input
Each line will contain an integers. Process to end of file.
 


Output
For each case, output the result in a line.
 


Sample Input
  
  
100
 


Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 
这题本身不难,只用到大数加法,但是写完以后总是Memory Limit Exceeded,原因是用大数加法一位一位的加,后来改为每四位加,不会Memory Limit Exceeded,但是wrong answer,原因是输出时用printf("%d",a[N][i]);不应该用"%d",要先把最高位用printf("%d",a[N][i--]);输出,然后再用for(;i>=0;i--)printf("%4.4d",a[N][i]);输出,因为相加以后或相加再进为以后的数可能回是小于四位的数,这是就要把缺的零补上,%4.4d中,前边的4是按四位输出,像右对齐,左边不够的补空格,.4是把四位前边的空格补零,在这里也可以写成%.4d效果一样。
#include<stdio.h>
#include<string.h>
#define NUM 8000
#define MAX 600
int a[NUM][MAX];
int main()
{
	int i,j,k;
	for(i=0;i<NUM;i++)
	memset(a[i],0,sizeof(a[i]));
	a[1][0]=1;a[2][0]=1;a[3][0]=1;a[4][0]=1;
	for(i=5,k=0;i<NUM;i++)
	{
		for(j=0;j<MAX;j++)
		{
			a[i][j]+=(a[i-4][j]+a[i-3][j]+a[i-2][j]+a[i-1][j]);
			if(a[i][j]>=10000)
			{
				k=a[i][j];
				a[i][j]=k%10000;
				a[i][j+1]+=(k/10000);
			}
		}
	}
	int N;
	while(scanf("%d",&N)!=EOF)
	{
		for(i=MAX-1;i>0;i--)
		if(a[N][i]!=0) break;
		printf("%d",a[N][i--]);
		for(;i>=0;i--)
		printf("%4.4d",a[N][i]);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值