hdoj 2824 The Euler function(欧拉函数打表)



http://acm.hdu.edu.cn/showproblem.php?pid=2824

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3920    Accepted Submission(s): 1628


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 


Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 


Output
Output the result of (a)+ (a+1)+....+ (b)
 


Sample Input
  
  
3 100
 


Sample Output
  
  
3042

#include<stdio.h>
#include<string.h>
#define MAX 3000000
int phi[MAX+10];//欧拉函数phi 
void Euler() 
{//打表 
	int i,j;
	memset(phi,0,sizeof(phi));
	for(i=1;i<=MAX;i++)
	phi[i]=i;
	for(i=2;i<=MAX;i+=2)
	phi[i]/=2;
	for(i=3;i<=MAX;i+=2)
	if(phi[i]==i)
	{
		for(j=i;j<=MAX+10;j+=i)
		phi[j]=phi[j]-phi[j]/i;
	}
} 
int main()
{
    int n,a,b;
    __int64 sum;
    Euler();
    while(scanf("%d %d",&a,&b)!=EOF)
    {
    	for(n=a,sum=0;n<=b;n++)
    	sum+=phi[n];
    	
    	printf("%I64d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值