HDU - 4027 Can you answer these queries?

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6

这个题神坑,开始 一直被这个rounded down 困扰  事实证明有道词典有待改善。。。。。

        

然后这个题暴力就可以了,但是一直是wrong answer  ,后来扫了眼别人的代码 看到这个 输入的两个数可能是先输入大的后输入小的,神tmd知道有这么修改的抓狂抓狂抓狂

wa了一下午加一个晚上。好悲哀。。。难过

#include<stdio.h>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;
const int maxn=100000+10;
ll a[maxn];
ll A[maxn*4];
void build(ll p,ll l,ll r){
    if(l==r){
        A[p]=a[l];
        return ;
    }
    ll mid=(l+r)>>1;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
    A[p]=A[p*2]+A[p*2+1];
}
void change(ll p,ll l,ll r,ll x,ll y){
    if(x>r||y<l)
       return ;
    if(x<=l&&r<=y){
        if(l==r){
            A[p]=(ll)(sqrt((double)A[p]));
            return ;
        }
        if(A[p]==r-l+1){
        return ;
        }

    }
    ll mid=(l+r)>>1;
    change(p*2,l,mid,x,y);
    change(p*2+1,mid+1,r,x,y);
    A[p]=A[p*2]+A[p*2+1];
}
ll query(ll p,ll l,ll r,ll x,ll y){
    if(x<=l&&r<=y)
        return A[p];
    ll ans=0;
    ll mid=(l+r)>>1;
    if(x<=mid)  ans+=query(p*2,l,mid,x,y);
    if(y>mid)  ans+=query(p*2+1,mid+1,r,x,y);
    return ans;
}
int main(){
    ll n;
    int ca=1;
    while(scanf("%lld",&n)!=EOF){
        for(int i=1;i<=n;i++){
            scanf("%lld",&a[i]);
        }
        build(1,1,n);
        int q;
        scanf("%d",&q);
        printf("Case #%d:\n",ca++);
        for(int i=0;i<q;i++){
            ll c,x,y;
            scanf("%lld%lld%lld",&c,&x,&y);
            if(x>y)
                swap(x,y);
            if(c==0)
                change(1,1,n,x,y);
            else{
                printf("%lld\n",query(1,1,n,x,y));
            }
        }
        printf("\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值