LightOJ 1027 A Dangerous Maze

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.


Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

题意是这样的:

你身处迷宫中,面前有n个门,每次都可以任选一个门,如果门的时间是正数,则表示t时间后会走出迷宫,反之表示t时间后返回原地,返回原地后不会记得之前的选择,还要重新选择,求走出迷宫的时间期望,如果走不出去输出“inf”;

有两种情况:

(1)选中的门的t为正,则期望为t/n;

(2)选中的门t为负,则回到原地期望为t/n,出去的期望为(t+E)/n;

设sum1,sum2分别为t为正的门的时间总和和t为负的门的时间总和;door1,door2分别为t为正的门的个数和t为负的门的个数;

则E=sum1/N+(sum2+door2*E)/N;化简得E=(sum1+sum2)/door1;

下面是代码:

#include <iostream>

using namespace std;

int gcd(int a, int b){
    if(a<b){
        a=a+b;
        b=a-b;
        a=a-b;
    }
    return a%b==0?b:gcd(b, a%b);
}
int main(){

    int T;
    cin >> T;
    int cnt=0;
    while(T--){
        cnt++;
        int sum1, sum2, door1, door2;
        sum1=sum2=door1=door2=0;
        int n;
        cin >> n;
        for(int i=1; i<=n; i++){
            int x;
            cin >> x;
            if(x>0){
                sum1+=x;
                door1++;
            }
            else{
                sum2+=(-x);
                door2++;
            }
        }
        cout << "Case " << cnt << ": ";
        if(door1==0) cout << "inf\n";
        else{
            int x=(sum1+sum2)/gcd(sum1+sum2, door1);
            int y=door1/gcd(sum1+sum2, door1);
            cout << x << '/' << y << endl;
        }
    }

    return 0;
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值