【大数】N!

描述

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

输入

One N in one line, process to the end of file.

输出

For each N, output N! in one line.

样例输入

1
2
3

样例输出
1
2
6
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int a[50050],n;
while(cin>>n)
{
int k;
memset(a,0,sizeof(a));
a[0]=1;
int t=1,c;
for (int i=1;i<=n;i++)
{
k=0;
for (int j=0;j<t;j++)
{
c=a[j]*i+k;
a[j]=c%10;
k=c/10;
}
while(k)
{
a[t++]=k%10;
k=k/10;
}
}
for (int i=t-1;i>=0;i–) cout<<a[i];
cout<<endl;
}
return 0;
}

分析:大数模板题,cin和cout比scanf快,或者preread也行。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值