3795: Javabeans 分享至QQ空间
时间限制(普通/Java):1000MS/3000MS 内存限制:65536KByte
总提交: 278 测试通过:175
描述
Javabeans are delicious. Javaman likes to eat javabeans very much.
Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,…n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible. So how many days it costs for him to eat all the javabeans?
输入
There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.
Each test case is a line of a positive integer 0 < n < 231.
输出
For each test case output the result in a single line.
样例输入
4
1
2
3
4
样例输出
1
2
2
3
分析:递推公式得f(x)=1+f(x/2);
代码:
#include<bits/stdc++.h>
using namespace std;
int doit(int x)
{
if (x==1) return 1;
return 1+doit(x/2);
}
int main()
{
int T;
cin>>T;
while(T–)
{
int n;
cin>>n;
cout<<doit(n)<<endl;
}
return 0;
}