Sumsets

Sumsets

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

  1. 1+1+1+1+1+1+1
  2. 1+1+1+1+1+2
  3. 1+1+1+2+2
  4. 1+1+1+4
  5. 1+2+2+2
  6. 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

解题思路

这个题看到的时候总觉得很熟悉,曾今在哪里做过,应该是在高中做过,那么用当时的想法来想可能会好理解些,可能会有些笨拙而已。实际上这个题放在曾今无非就是找规律题而已,叫我们求一个数列的通项公式,那我们写那么些例子出来找规律就对了。我们建立一个数组,用于存放每个数字的数字组种数,索引从一开始,与数字形成对应。那么这里是建立了数组d[1000010]
那么从1开始
1:

1)1
d[1]=1

2:

1)1+1
2)2
d[2]=2

3:

1)1+1+1
2)1+2
d[3]=2

4:

1)1+1+1+1
2)1+1+2
3)2+2
4)4
d[4]=4

5:

1)1+1+1+1+1
2)1+1+1+2
3)1+2+2
4)1+4
d[5]=4

6:

1)1+1+1+1+1+1
2)1+1+1+1+2
3)1+1+2+2
4)1+1+4
5)2+2+2
6)2+4
d[6]=6

7:

1)1+1+1+1+1+1+1
2)1+1+1+1+1+2
3)1+1+1+2+2
4)1+1+1+4
5)1+2+2+2
6)1+2+4
d[7]=6

8:

1)1+1+1+1+1+1+1+1
2)1+1+1+1+1+1+2
3)1+1+1+1+2+2
4)1+1+1+1+4
5)1+1+2+2+2
6)1+1+2+4
7)2+2+2+2
8)2+2+4
9)4+4
10)8
d[8]=10

9:

1)1+1+1+1+1+1+1+1+1
2)1+1+1+1+1+1+1+2
3)1+1+1+1+1+2+2
4)1+1+1+1+1+4
5)1+1+1+2+2+2
6)1+1+1+2+4
7)1+2+2+2+2
8)1+2+2+4
9)1+4+4
10)1+8
d[9]=10

其实写到7就基本上可以看出规律了,不过多写两项可以让我们更加确信自己的猜想,那么下面就分析一下从上面所做的工作中找出的规律
当n≥3时,有这样的规律:
1.n为奇数时:
d[n]=d[n-1]
2.n为偶数时:
(1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为d[n-2];
(2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为d[n/2];
所以总的种类数为:d[n]=d[n-2]+d[n/2];
那么此题就瞬间变得很简单了,只需要注意其中一点:数字的尺寸太大则仅打印最后9位数(以10为基数表示)

C++编写:

#include<iostream>
using namespace std;

int N;
int  d[1000010];
int main()
{
    ios::sync_with_stdio(false);
    d[1]=1,d[2]=2;
    for(int i=3;i<=1000000;i++)
    {
        if(i%2==0)
            d[i]=d[i-2]+d[i/2];
        else
            d[i]=d[i-1];
        d[i]%=1000000000;      //仅保留最后9位数
    }
    while(cin>>N)
        cout<<d[N]<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值