Milking Cows

Milking Cows

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

• The longest time interval at least one cow was milked.
• The longest time interval (after milking starts) during which no cows were being milked.

INPUT FORMAT

Line 1:The single integer, N
Lines 2~N+1:Two non-negative integers less than 1,000,000, respectively the starting and ending time in seconds after 0500

SAMPLE INPUT

3
300 1000
700 1200
1500 2100

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

SAMPLE OUTPUT

900 300

C++编写:

这道题题意还是很简单,要求求一个最大挤奶时间(该时间段内至少有一头奶牛在挤奶)和最大间隔时间(该时间段内没有任何奶牛在挤奶) ,不过调试得我异常的艰辛,调了半天,结果就是一个地方写错了,后面会谈到,大家可以注意一下这些地方,那么代码如下:

/*
ID: your_id_here
TASK: milk2
LANG: C++                 
*/
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAX_N=5010;

struct Cow{
    int begin;
    int end;
}milk[MAX_N];

int N;

bool compare(const Cow &a,const Cow &b)
{
    if(a.begin == b.begin)
        return a.end<b.end;
    return a.begin<b.begin;               /*按照挤奶开始时间从早到晚排列,如果开始时间相同,则早结束的排在前面*/
}

void solve()
{
    Cow t = milk[0];
    int max_con=t.end-t.begin,max_idle=0;
    int max1=max_con;

    for(int i=1;i<N;i++)
    {        
        if(milk[i].end <= t.end)
            continue;
        if(milk[i].begin <= t.end)
        {
            max1+=milk[i].end-t.end;
            t=milk[i];
        }
        else
        {
            max_idle=max(max_idle,milk[i].begin-t.end);
            t=milk[i];
            max1=milk[i].end-milk[i].begin;
        }
        max_con=max(max_con,max1);
    }
    cout<<max_con<<" "<<max_idle<<endl;
}

int main()
{
    freopen("milk2.in","r",stdin);
    freopen("milk2.out","w",stdout);

    cin>>N;
    for(int i=0;i<N;i++)
        cin>>milk[i].begin>>milk[i].end;

    sort(milk,milk+N,compare);
    solve();
    return 0;
}

现在来谈一下调了很久才找到的错误,主要是solve()函数里面的for循环里有两行写得有问题,并且还不难发现,起初写出来的错误代码是下面这样的:

for(int i=1;i<N;i++)
{        
    if(milk[i].end <= t.end)
        continue;
    if(milk[i].begin <= t.end)
    {
        max1+=milk[i].end-milk[i-1].end;
        t=milk[i];
    }
    else
    {
        max_idle=max(max_idle,milk[i].begin-milk[i-1].end);
        t=milk[i];
        max1=milk[i].end-milk[i].begin;
    }
    max_con=max(max_con,max1);
}

感觉上其实没问题,max1加上后一个的结束时间减去前一个的结束时间,当时USACO上1000个数据我也不想去找然后又不知道错哪儿,然后后来我自己想了两组数据,带入代码一看就明白了:
第一组(针对与求max_con会出现错误):

4
5 10
6 8
7 9
9 12

理论应得:

7 0

实际会得:

8 0

第二组(针对于求max_idle会出现错误):

4
5 10 
6 8
7 9
12 15

理论应得:

5 2

实际会得:

5 3
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
02-12

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值