6th Jilin Province Collegiate Programming Contest——Problem I: Crossword

问题描述:

http://acm.jlu.edu.cn/joj/showproblem.php?pid=2778&contestid=199

Xiao Ming is  very busy. Xiao Fang, one of his classmates, want to send some 

small paper pieces to Xiao Ming. She doesn‟t want to let other students know these 
private messages. So, she encrypt the message using the pattern followed. She 
draws a minimum n*n square that can contain total characters at first. Secondly she 
writes these characters from left to right, top to bottom. At last, she rewrite these 
characters in square to a new string from top to bottom, left to right. The new string is 
passed to Xiao Ming.
Let us see an example:
If Xiao Fang want to write  “ABCDEFG”, she draw a 3*3 (3 is most suitable)
square, and fill letters in it as follows:
ABC
DEF
G
At last, she rewrite these letters as “ADGBECF”. All the blanks are omitted.
Can you write a program to help Xiao Fang encrypt her private message?
Input
The first line is the number of test cases. Each line followed is a string which only 
consist alphabet („a‟-„z‟, „A‟-„Z‟). The length of string is no more than 100.
Output
For each case, print the encrypted string in one line.
Sample Input
2
ABCDEFG
abcdefghijk
Sample Output
ADGBECF

aeibfjcgkdh

参考代码:

#include<iostream>
#include<string>
#include<cmath>
using namespace std;

string *str;
char cl[10][10];

int main()
{
	int ln;
	cin>>ln;
	str=new string[ln];
	for(int k=0;k<ln;k++)
	{
		cin>>str[k];
	}
	for(int k=0;k<ln;k++)
	{
		int length=str[k].length();
		float nn=sqrt((float)str[k].length());
		int n;
		if((nn-(int)(nn/1))>0)
			n=(int)nn+1;
		else
			n=(int)nn;

		for(int i=0;i<length;i++)
		{
			cl[i/n][i%n]=str[k][i];
		}
		int j,m=n*n;
		for(j=0;j<m;j++)
		{
			if((j%n*n+j/n)<length)
				cout<<cl[j%n][j/n];
		}
		cout<<endl;
	}
	return 0;
}

这个题原本看来很简单,所以就没好好做,半个点写完了代码。结果运行用题目参考的测试数据能得到正确结果,但是一提交就出现错误...郁闷了,也是在没想出来自己算法的逻辑哪有错误。后来没辙了,就找了个牛点的哥们给看的,结果郁闷死了,原本代码:

int n=sqrt((float)str[k].length())+1;

这边处理错误了,如果字符长正好可以被开方,就不用加1了。所以要加判断条件的,给忽略了,改正如下:

int n;
if((nn-(int)(nn/1))>0)
      n=(int)nn+1;
else
      n=(int)nn;

虽然题目很简单,犯的错也挺二,但起码让我知道了,一个是不能太“轻敌”;然后一个技术方面的技巧,做测试的时候不能只用题目的,还要自己多找几组,不同类型的,尤其那些临界的数据!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值