北京大学2013计算机所本科生保研夏令营考试——E:Oil Deposits

原题链接:http://poj.grids.cn/jss2013/E/

题目描述:

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
输入
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

输出
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
样例输入
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
样例输出
0
1
2
2
参考代码:

我写的这个代码比较挫,太长了,很有改进的空间...但是结果是正确的,能够通过编译!

#include<iostream>
using namespace std;

char grids[101][101];
int visited[101][101];
int nexti[101];
int nextj[101];
int ct=0;
int num=0;
int m,n;

int main()
{
	freopen("data.in","r",stdin);
	cin>>m>>n;
	while(m!=0&&n!=0)
	{
		for(int i=1;i<=m;i++)
		{
			for(int j=1;j<=n;j++)
			{
				cin>>grids[i][j];
			}
		}

		for(int i=1;i<=m;i++)
		{
			for(int j=1;j<=n;j++)
			{
				visited[i][j]=0;
			}
		}

		for(int i=1;i<=m;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(visited[i][j]==0)
				{
					if(grids[i][j]=='@')
					{
						num=0;
						nexti[num]=i;
						nextj[num]=j;
						num++;
						visited[i][j]=++ct;
						int k=0;
						while(k<num)
						{
							if(nexti[k]>1&&nextj[k]>1)
							{
								if(visited[nexti[k]-1][nextj[k]-1]==0&&grids[nexti[k]-1][nextj[k]-1]=='@')
								{
									nexti[num]=nexti[k]-1;
									nextj[num]=nextj[k]-1;
									num++;
									visited[nexti[k]-1][nextj[k]-1]=ct;
								}
								else
									visited[nexti[k]-1][nextj[k]-1]=100001;
							}
							if(nexti[k]>1)
							{
								if(visited[nexti[k]-1][nextj[k]]==0&&grids[nexti[k]-1][nextj[k]]=='@')
								{
									nexti[num]=nexti[k]-1;
									nextj[num]=nextj[k];
									num++;
									visited[nexti[k]-1][nextj[k]]=ct;
								}
								else
									visited[nexti[k]-1][nextj[k]]=100001;
							}
							if(nexti[k]>1&&nextj[k]<n)
							{
								if(visited[nexti[k]-1][nextj[k]+1]==0&&grids[nexti[k]-1][nextj[k]+1]=='@')
								{
									nexti[num]=nexti[k]-1;
									nextj[num]=nextj[k]+1;
									num++;
									visited[nexti[k]-1][nextj[k]+1]=ct;
								}
								else
									visited[nexti[k]-1][nextj[k]+1]=100001;
							}
							if(nextj[k]>1)
							{
								if(visited[nexti[k]][nextj[k]-1]==0&&grids[nexti[k]][nextj[k]-1]=='@')
								{
									nexti[num]=nexti[k];
									nextj[num]=nextj[k]-1;
									num++;
									visited[nexti[k]][nextj[k]-1]=ct;
								}
								else
									visited[nexti[k]][nextj[k]-1]=100001;
							}
							if(nextj[k]<n)
							{
								if(visited[nexti[k]][nextj[k]+1]==0&&grids[nexti[k]][nextj[k]+1]=='@')
								{
									nexti[num]=nexti[k];
									nextj[num]=nextj[k]+1;
									num++;
									visited[nexti[k]][nextj[k]+1]=ct;
								}
								else
									visited[nexti[k]][nextj[k]+1]=100001;
							}
							if(nexti[k]<m&&nextj[k]>1)
							{
								if(visited[nexti[k]+1][nextj[k]-1]==0&&grids[nexti[k]+1][nextj[k]-1]=='@')
								{
									nexti[num]=nexti[k]+1;
									nextj[num]=nextj[k]-1;
									num++;
									visited[nexti[k]+1][nextj[k]-1]=ct;
								}
								else
									visited[nexti[k]+1][nextj[k]-1]=100001;
							}
							if(nexti[k]<m)
							{
								if(visited[nexti[k]+1][nextj[k]]==0&&grids[nexti[k]+1][nextj[k]]=='@')
								{
									nexti[num]=nexti[k]+1;
									nextj[num]=nextj[k];
									num++;
									visited[nexti[k]+1][nextj[k]]=ct;
								}
								else
									visited[nexti[k]+1][nextj[k]]=100001;
							}
							if(nexti[k]<m&&nextj[k]<n)
							{
								if(visited[nexti[k]+1][nextj[k]+1]==0&&grids[nexti[k]+1][nextj[k]+1]=='@')
								{
									nexti[num]=nexti[k]+1;
									nextj[num]=nextj[k]+1;
									num++;
									visited[nexti[k]+1][nextj[k]+1]=ct;
								}
								else
									visited[nexti[k]+1][nextj[k]+1]=100001;
							}
							k++;
						}
					}
				}
			}
		}
		cout<<ct<<endl;
		ct=0;
		cin>>m>>n;
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值