POJ-1753:Flip Game

题目描述:

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
输入
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
输出
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
样例输入
bwwb
bbwb
bwwb
bwww
样例输出
4

思路就是深搜遍历尽所有的翻转0次、1次、2次、3次...直到大于16次之后就代表了不可能的情况。


参考代码:

#include<iostream>
#include<fstream>
using namespace std;

int chess[4][4];
bool flag=false;
int step=0;

bool check() //检查所有的棋子颜色是否处于一致的状态
{
	for(int i=0;i<4;i++)
	{
		for(int j=0;j<4;j++)
		{
			if(chess[i][j]!=chess[0][0])
				return false;
		}
	}
	return true;
}

void flip(int row,int col) //进行反转操作函数
{
	chess[row][col]=!chess[row][col];
	if(row>0)
		chess[row-1][col]=!chess[row-1][col];
	if(row<3)
		chess[row+1][col]=!chess[row+1][col];
	if(col>0)
		chess[row][col-1]=!chess[row][col-1];
	if(col<3)
		chess[row][col+1]=!chess[row][col+1];
}

void dfs(int row,int col,int deep)//深搜函数,row行;row列;deep搜索的深度,也就是操作了几个棋子
{
	if(deep==step)                //当前搜索深度等于预设的深度,要结束
	{
		flag=check();
		return;
	}

	if(flag||row==4)             //flag判断条件是作为找到答案后向上返回用的;row=4是搜索的限度已经超出了棋盘范围
		return;

	flip(row,col);               //进行翻转之后进入下次层进行搜索
	if(col<3)
		dfs(row,col+1,deep+1);
	else
		dfs(row+1,0,deep+1);

	flip(row,col);              //失败之后,撤销翻转操作。然后对下一个棋格进行操作
	if(col<3)
		dfs(row,col+1,deep);
	else
		dfs(row+1,0,deep);
	
	return;

}

int main()
{
	freopen("data.in","r",stdin);
	char ch;
	for(int i=0;i<4;i++)  //输入,为了简单操作,把字符换做了0,1数字
	{
		for(int j=0;j<4;j++)
		{
			cin>>ch;
			if('b'==ch)
				chess[i][j]=0;
			else
				chess[i][j]=1;
		}
	}
	for(step=0;step<=16;step++)//开始迭代所有要进行的操作次数
	{
		dfs(0,0,0);
		if(flag)
		{
			cout<<step<<endl;
			return 0;
		}
	}
	cout<<"Impossible"<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值