S 1.1 friday C/C++ 程序

题目:http://ace.delos.com/usacoprob2?a=0bWeXBwSLRg&S=friday

 

题目:

Friday the Thirteenth

Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400.

Note that the start year is NINETEEN HUNDRED, not 1990.

There are few facts you need to know before you can solve this problem:

  • January 1, 1900 was on a Monday.
  • Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
  • Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
  • The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.

Do not use any built-in date functions in your computer language.

Don't just precompute the answers, either, please.

PROGRAM NAME: friday

INPUT FORMAT

One line with the integer N.

SAMPLE INPUT (file friday.in)

20

OUTPUT FORMAT

Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday, Monday, Tuesday, ..., Friday.

SAMPLE OUTPUT (file friday.out)

36 33 34 33 35 35 34


 

题目翻译:

描述

13号又是一个星期五。13号在星期五比在其他日子少吗?为了回答这个问题,写一个程序,要求计算每个月的十三号落在周一到周日的次数。给出N年的一个周期,要求计算1900年1月1日至1900+N-1年12月31日中十三号落在周一到周日的次数,N为正整数且不大于400.

这里有一些你要知道的:

1、1900年1月1日是星期一.
2、4,6,11和9月有30天.其他月份除了2月都有31天.闰年2月有29天,平年2月有28天.
3、年份可以被4整除的为闰年(1992=4*498 所以 1992年是闰年,但是1990年不是闰年).
4、以上规则不适合于世纪年。可以被400整除的世纪年为闰年,否则为平年。所以,1700,1800,1900和2100年是平年,而2000年是闰年.

请不要调用现成的函数

请不要预先算好数据(就是叫不准打表)!

[编辑] 格式

PROGRAM NAME: friday

INPUT FORMAT:

(friday.in)

一个正整数n.

OUTPUT FORMAT:

(friday.out)

七个在一行且相分开的整数,它们代表13日是星期六,星期日,星期一...星期五的次数..

[编辑] 输入格式

20

[编辑] 输出格式

36 33 34 33 35 35 34

 

题目求解:

 

方法一:c程序

 

/*
ID:smilecl1
LANG:C
TASK:friday
*/

/*
TIME:2012年10月30日
*/

#include <stdio.h>
#include <stdlib.h>

int main()
{
    FILE *fin;
    FILE *fout;
    int count[7]={0};
    int month_count[12]={31,28,31,30,31,30,31,31,30,31,30,31};
    int year=1900;
    int n;
    int day=6;
    int i=0;
    int j=0;

    fin=fopen("friday.in","r");
    fout=fopen("friday.out","w");
    fscanf(fin,"%d",&n);
    for(i=0;i!=n;++i)
    {
        if ( ( (0==year%4) && (0!=year%100) ) || (0==year%400)  )
        {
            month_count[1]=29;
        }
        else
        {
            month_count[1]=28;
        }
        for (j=0;j!=12;++j)
        {
            count[day]++;
            day+=month_count[j];
            day%=7;
        }
        month_count[1]=28;
        year++;//之前在此犯了低级错误,用了year=year+i;这样子最后的year不是year+n;得到不正确的结果
    }

   fprintf(fout,"%d",count[6]);
    for(i=0;i!=6;++i)
    {
        fprintf(fout," %d",count[i]);
    }
    fprintf(fout,"\n");
    return 0;
}

 

方法二:C++程序

 

/*
ID:smilecl1
LANG:C++
TASK:friday
*/

#include <fstream>
using namespace std;

int main()
{
    ifstream fin("friday.in");
    ofstream fout("friday.out");

    int count[7]={0};
    int month_count[12]={31,28,31,30,31,30,31,31,30,31,30,31};
    int year=1900;
    int n;
    int day=6;
    int i=0;
    int j=0;

    fin>>n;
    for(i=0;i!=n;++i)
    {
        if ( ( (0==year%4) && (0!=year%100) ) || (0==year%400)  )
        {
            month_count[1]=29;
        }
        else
        {
            month_count[1]=28;
        }
        for (j=0;j!=12;++j)
        {
            count[day]++;
            day+=month_count[j];
            day%=7;
        }
        month_count[1]=28;
        year++;//之前在此犯了低级错误,用了year=year+i;这样子最后的year不是year+n;得到不正确的结果
    }

    fout<<count[6];
    for(i=0;i!=6;++i)
    {
        fout<<" "<<count[i];
    }
    fout<<endl;
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值