POJ 3723 - Conscription(最大生成树)

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11940 Accepted: 4209
Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.
Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133
Sample Output

71071
54223

题意:
要找n个女性和m个男性,每个人的费用是10000,但是如果要招的女性和已经招的男性有d的关系,他们的费用就能减免d,问最后花费最少是多少.

解题思路:
最大生成树裸题.优先选择权值最大的边.这题用的是Kruskal算法,存储图的方式是边集.
对边的权值进行从大到小的排序,贪心选择权值最大的边(通过并查集,看该边如果选中是否会形成环).

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{int x,y,v;}edge[50000];
int f[20000];
int n,m,r;
bool cmp(node a,node b) {return a.v>b.v;}
int Find(int pos)
{
    return f[pos] == -1?pos:f[pos]=Find(f[pos]);
}
bool un(int a,int b)
{
    int fa = Find(a);
    int fb = Find(b);
    if(fa == fb)    return 0;
    f[fa] = fb;     return 1;
}
int kruskal()
{
    sort(edge,edge+r,cmp);
    int ans = 0;
    for(int i = 0;i < r;i++)
        if(un(edge[i].x,edge[i].y+n)) ans += edge[i].v;
    return ans;
}
int main()
{
    int loop;
    scanf("%d",&loop);
    while(loop--)
    {
        memset(f,-1,sizeof(f));
        scanf("%d%d%d",&n,&m,&r);
        for(int i = 0;i < r;i++)    scanf("%d%d%d",&edge[i].x,&edge[i].y,&edge[i].v);
        printf("%d\n",(n+m)*10000-kruskal());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值