HDU 1710 - Binary Tree Traversals(树的遍历)

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6482 Accepted Submission(s): 3013

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

Output
For each test case print a single line specifying the corresponding postorder sequence.

Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

Sample Output
7 4 2 8 9 5 6 3 1

题意:
给出二叉树的前序遍历和中序遍历结果,要求输出后序遍历的结果。

解题思路:
因为有中序遍历,所以对于每一棵子树的根节点是多少,就可以将左子树和右子树划分出来。
给出了前序遍历,那么给出的第一个节点就是当前子树的根节点。
找到根节点后,就对左子树和右子树进行同样的操作。

AC代码:

#include<stdio.h>
const int maxn = 1e3+5;
int pre[maxn];
int mid[maxn];
void fun(int start1,int start2,int len,bool flag)
{
    if(len == 1)
    {
        printf("%d ",pre[start1]);
        return ;
    }
    else if(len <= 0)   return ;
    int index;
    for(index = 0;index<len && pre[start1] != mid[start2+index];index++);
    fun(start1+1,start2,index,false);
    fun(start1+1+index,start2+1+index,len-index-1,false);
    if(flag)    printf("%d\n",pre[start1]);
    else        printf("%d ",pre[start1]);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i = 0;i < n;i++)    scanf("%d",&pre[i]);
        for(int i = 0;i < n;i++)    scanf("%d",&mid[i]);
        fun(0,0,n,true);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值