USACO-Section 3.2-PROB Magic Squares

Magic Squares
IOI'96

Following the success of the magic cube, Mr. Rubik invented its planar version, called magic squares. This is a sheet composed of 8 equal-sized squares:

1234
8765

In this task we consider the version where each square has a different color. Colors are denoted by the first 8 positive integers. A sheet configuration is given by the sequence of colors obtained by reading the colors of the squares starting at the upper left corner and going in clockwise direction. For instance, the configuration of Figure 3 is given by the sequence (1,2,3,4,5,6,7,8). This configuration is the initial configuration.

Three basic transformations, identified by the letters `A', `B' and `C', can be applied to a sheet:

  • 'A': exchange the top and bottom row,
  • 'B': single right circular shifting of the rectangle,
  • 'C': single clockwise rotation of the middle four squares.

Below is a demonstration of applying the transformations to the initial squares given above:

A:
8765
1234
B:
4123
5876
C:
1724
8635

All possible configurations are available using the three basic transformations.

You are to write a program that computes a minimal sequence of basic transformations that transforms the initial configuration above to a specific target configuration.

PROGRAM NAME: msquare

INPUT FORMAT

A single line with eight space-separated integers (a permutation of (1..8)) that are the target configuration.

SAMPLE INPUT (file msquare.in)

2 6 8 4 5 7 3 1 

OUTPUT FORMAT

Line 1:A single integer that is the length of the shortest transformation sequence.
Line 2:The lexically earliest string of transformations expressed as a string of characters, 60 per line except possibly the last line.

SAMPLE OUTPUT (file msquare.out)

7
BCABCCB

搜索题。注意对string和map的运用
要给string的某一位赋值,前提是它已经被赋值

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<queue>
#define name "msquare"
using namespace std;
map <string,int> num;
struct father
{
	int f;//是由谁变来的 
	char c;//变的方式 
}fa[1000000];
queue <string> Q;
string s,t;
char ABC[100000];
int ans,tot;
void print()
{
	int x=0,y=tot+1;
	while (y!=0)
	{
		ABC[++x]=fa[y].c;
		y=fa[y].f;
	}
	cout<<x<<endl;
	int tmp;
	for (int i=x;i>=1;i--)
	{
		tmp++;
	    cout<<ABC[i];
	    if (tmp==60) cout<<endl;
    }
	cout<<endl;
}
void bfs()
{
	int i,j;
	while (!Q.empty())
	{
		string now=Q.front();
		Q.pop();
		string tmp="00000000";
		for (i=0;i<=7;i++)
		tmp[i]=now[7-i];
		//cout<<tmp<<endl;
		if (string(t)==string(tmp)) {fa[tot+1].f=num[now];fa[tot+1].c='A';print();break;}
		if (num[tmp]==0) 
		{
			Q.push(tmp);
			++tot;
			num[tmp]=tot;
			fa[tot].f=num[now];
			fa[tot].c='A';
		}
		tmp[0]=now[3];tmp[7]=now[4];
		tmp[1]=now[0];tmp[2]=now[1];tmp[3]=now[2];
		tmp[6]=now[7];tmp[5]=now[6];tmp[4]=now[5];
		//cout<<tmp<<endl;
		if (string(t)==string(tmp)) {fa[tot+1].f=num[now];fa[tot+1].c='B';print();break;}
		if (num[tmp]==0) 
		{
			Q.push(tmp);
			++tot;
			num[tmp]=tot;
			fa[tot].f=num[now];
			fa[tot].c='B';
		}
		tmp=now;
		tmp[1]=now[6];tmp[2]=now[1];
		tmp[5]=now[2];tmp[6]=now[5];
		//cout<<tmp<<endl;
		if (string(t)==string(tmp)) {fa[tot+1].f=num[now];fa[tot+1].c='C';print();break;}
		if (num[tmp]==0) 
		{
			Q.push(tmp);
			++tot;
			num[tmp]=tot;
			fa[tot].f=num[now];
			fa[tot].c='C';
		}
	}
}
int main()
{
	freopen(name ".in","r",stdin);
	freopen(name ".out","w",stdout);
	int i,j;
	t="00000000";
	for (i=0;i<=7;i++)
	    cin>>t[i];
	//cout<<t;
    s="12345678";
    if (t=="12345678") {cout<<"0";cout<<endl<<endl;return 0;}
    num[s]=0;
    Q.push(s);
    bfs();
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
水资源是人类社会的宝贵财富,在生活、工农业生产中是不可缺少的。随着世界人口的增长及工农业生产的发展,需水量也在日益增长,水已经变得比以往任何时候都要珍贵。但是,由于人类的生产和生活,导致水体的污染,水质恶化,使有限的水资源更加紧张。长期以来,油类物质(石油类物质和动植物油)一直是水和土壤中的重要污染源。它不仅对人的身体健康带来极大危害,而且使水质恶化,严重破坏水体生态平衡。因此各国都加强了油类物质对水体和土壤的污染的治理。对于水中油含量的检测,我国处于落后阶段,与国际先进水平存在差距,所以难以满足当今技术水平的要求。为了取得具有代表性的正确数据,使分析数据具有与现代测试技术水平相应的准确性和先进性,不断提高分析成果的可比性和应用效果,检测的方法和仪器是非常重要的。只有保证了这两方面才能保证快速和准确地测量出水中油类污染物含量,以达到保护和治理水污染的目的。开展水中油污染检测方法、技术和检测设备的研究,是提高水污染检测的一条重要措施。通过本课题的研究,探索出一套适合我国国情的水质污染现场检测技术和检测设备,具有广泛的应用前景和科学研究价值。 本课题针对我国水体的油污染,探索一套检测油污染的可行方案和方法,利用非分散红外光度法技术,开发研制具有自主知识产权的适合国情的适于野外便携式的测油仪。利用此仪器,可以检测出被测水样中亚甲基、甲基物质和动植物油脂的污染物含量,为我国众多的环境检测站点监测水体的油污染状况提供依据。
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值