ACM-ICPC 2018 南京赛区网络预赛__E AC Challenge【状态压缩+DP】

  •  1000ms
  •  128536K

Dlsj is competing in a contest with n(0<n≤20) problems. And he knows the answer of all of these problems.

However, he can submit i-th problem if and only if he has submitted (and passed, of course) si​ problems, the pi,1​-th,pi,2​-th, ......, pi,si​​-th problem before.(0<pi,j​≤n,0<j≤si​,0<i≤n) After the submit of a problem, he has to wait for one minute, or cooling down time to submit another problem. As soon as the cooling down phase ended, he will submit his solution (and get "Accepted" of course) for the next problem he selected to solve or he will say that the contest is too easy and leave the arena.

"I wonder if I can leave the contest arena when the problems are too easy for me."
"No problem."
—— CCF NOI Problem set

If he submits and passes the ii-th problem on tt-th minute(or the tt-th problem he solve is problem i), he can get t×ai​+bi​ points. (∣ai​∣,∣bi​∣≤109).

Your task is to calculate the maximum number of points he can get in the contest.

Input

The first line of input contains an integer, n, which is the number of problems.

Then follows n lines, the i-th line contains si​+3 integers, ai​,bi​,si​,p1​,p2​,...,psi​​ as described in the description above.

Output

Output one line with one integer, the maximum number of points he can get in the contest.

Hint

In the first sample.

On the first minute, Dlsj submitted the first problem, and get 1×5+6=11 points.

On the second minute, Dlsj submitted the second problem, and get 2×4+5=13 points.

On the third minute, Dlsj submitted the third problem, and get 3×3+4=13 points.

On the forth minute, Dlsj submitted the forth problem, and get 4×2+3=11 points.

On the fifth minute, Dlsj submitted the fifth problem, and get 5×1+2=7 points.

So he can get 11+13+13+11+7=55 points in total.

In the second sample, you should note that he doesn't have to solve all the problems.

样例输入1

5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4

样例输出1

55

样例输入

1
-100 0 0

样例输出2

0

题目来源

ACM-ICPC 2018 南京赛区网络预赛

题目大意:给n个问题,然后每个问题 给出a,b,s 分别表示 第i个解决这个题,就给 (a*i+b) 的得分,s表示有 s个前置问题,必须回答出来 s个前置问题 才能解决这个问题,求最大的得分,注意,可以不用答完所有的题

题解:状态压缩+DP。AC的C++代码:

#include<iostream>

using namespace std;
typedef long long ll;
const ll INF=1e18;
const int N=21;
struct Problem{
	ll a,b;
	int pre;
}p[N];

ll dp[1<<N];

int main()
{
	int n,s,x;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%lld%lld%d",&p[i].a,&p[i].b,&s);
		p[i].pre=0;
		while(s--){
			scanf("%d",&x);
			p[i].pre|=(1<<(x-1));
		}
	}
	for(int i=0;i<(1<<n);i++)//将所有状态置为-INF 
	  dp[i]=-INF;
	dp[0]=0;
	ll res=0; 
	for(int i=0;i<(1<<n);i++){//遍历所有状态
		if(dp[i]==-INF)//如果这个状态无法由初始状态得来就跳过 
		  continue;
		//解题顺序t等于已经解决的题数加一 
		int t=1; 
		//统计现在已经解决的题数,二进位为1的个数 
		for(int j=0;j<n;j++)
		  if(i&(1<<j))
		    t++;
		for(int j=0;j<n;j++){
			if(i&(1<<j)) continue;//如果第j到题已经做过了就跳过
           //如果第j道题还没做,
		   //且要解决第j题所需先要解决的问题已经解决,就进行更新
           if((p[j].pre&i)==p[j].pre){
        		int tmp=i|(1<<j);//解决第j道题后的状态
        		ll val=dp[i]+t*p[j].a+p[j].b;//解决第j道题后的总分 
			    dp[tmp]=max(dp[tmp],val);
			    res=max(res,dp[tmp]);
		   }   
		} 
	}
	printf("%lld\n",res); 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值